4700 Invalid redirect for whitelisted URL

Our staging environment no longer works to authorize zoom for our application.
Prior to changing our staging url, the zoom integration was working.
We updated our staging url and started getting Invalid redirect: Sign In | Lessonly (4,700)

I updated the whitelist urls support our new staging url and resubmitted the application, but we continue to get the error.

I have looked through the related posts, but haven’t found a solution yet.

Any help is appreciated!
Invalid redirect: Sign In | Lessonly (4,700)

How To Reproduce
Steps to reproduce the behavior:
When we call:

The response is:
Invalid redirect: https://dev.staging-1.lessonly.engineering/integrations/oauth/zoom/callback (4,700)

Our app is called Lessonly and is published. We republished and were approved after updating the whitelist.

Our whitelist urls are:

Our redirect url for production is:

Our redirect url for development is:

Hello have you tried this setting?

Redirect URI

Allow list

On the documentation states both should be with any

Hope this helps

Thanks for your response!

Our redirect uri is currently set for our production environment so I don’t think changing it is the best option for us. I do have https://any.staging-1.lessonly.engineering/integrations/oauth/zoom/callback as the redirect uri for our development redirect uri.

Does anyone have any other suggestions of where we might be going wrong? We need to keep support for production, but also allow this staging url. I’ve been hoping it would magically start working as that seems to be the resolution for other tickets with this error, but no luck yet.

@elisa.zoom any advice for us here?

Hey @ssakamoto
Thanks for reaching out and sorry I did not get to this thread earlier but I am happy to help
Would you mind adding the staging URL to the allow list exactly as you have it?


If I am understanding correctly you are just getting this error when testing your development instance is that correct?

Thanks for the quick response! Yes, its just when trying to access through the staging domain. I’ll try the full path.

Interesting @ssakamoto
Please let me know if adding the full path works and remember to submit your app for an update review so the changes get applied to your app