500 Internal Server Error during App Authorisation

Description
I am having the 500 Internal Server Error when I launch the App Authorisation using OAUTH2 app in order to get access token. My email and password are correct(can be signed in at Zoom), and it is the same email as the developer email field in Zoom OAUTH2 app. Th redirect uri are the same too.

Error


Which App Type (OAuth / Chatbot / JWT / Webhook)?
I am using OAUTH app

Which Endpoint/s?
This is the url/ the API that I am using ‘https://zoom.us/oauth/authorize?response_type=code&client_id=XXXXX&redirect_uri=$zmEncodedWSurl

How To Reproduce (If applicable)
Steps to reproduce the behavior:

var url ='https://zoom.us/oauth/authorize?response_type=code&client_id=0C4XBizXRNaLaoAs1BENw&redirect_uri=$zmEncodedWSurl';
final callbackUrlScheme = 'foobar';

final result = await FlutterWebAuth.authenticate(

 url: url, callbackUrlScheme: callbackUrlScheme);

I’m seeing this as well. Surprised no mention on https://status.zoom.us/ - seems to be an issue on Zoom’s end.

Yeah, I think so as I have been stucking at this for days

Hey @okzoomer, @gohsyang,

We are aware of this issue, it will be fixed this weekend.

Current work around is to login first here: zoom.us/signin and then go back to authorize the app.

Apologies for the inconvenience,
Tommy

Hi Tommy,

Am new to using Zoom APIs and first blocker is in OAuth itself. I’m using Postman to try the APIs and in token generation process get 500 internal server error. I am already logged into Zoom using both Chrome and Safari, not sure how to implement above recommended workaround in Postman. Will appreciate help.

We are also facing the same issue 500 internal server error for correct userName & password, please update us once it’s fixed.

Hey @AkshatSinghal, @integrationAnywhere,

This OAuth issue should be fixed, I tested and it worked.

Thanks,
Tommy

We also confirmed the fix for OAuth issue, its working fine. Thanks for the update.

1 Like

Happy to help! :slight_smile:

Thanks,
Tommy

I’m getting this error when trying to authenticate via SSO for the Slack/ Zoom integration. I see this thread but no answers on how to resolve

Hey @jimonte.johnson,

Please create a new topic and fill out the post template so we have enough info to help. :slight_smile:

Thanks,
Tommy

One of our user is facing error 500 while integrating zoom with slack:

Hey @tkumar,

Can you provide the steps necessary to reproduce the issue? Once we have some more details we’ll be happy to take a closer look.

Thanks!
Will

Hi,

I encountered a similar issue of 500 error when I tried to authorize Slack-Zoom integration on Slack. The steps are below:

  1. Type /zoom on a random slack channel.
  2. Click “Authorize Zoom” link and open a Zoom sing-in page on Google Chrome.
  3. Click “Sign-in with SSO” and type our domain name. (Using Okta as a IDaaS)
  4. Open a slack.com page which requires authentication. It says “Zoom is requesting permission to access the NESIC社内 Slack workspace.” (“NESIC社内” is the name of our workspace.)
  5. Click “Allow” and move to application.zoom.us
  6. It says

“Authorization Failure.
500 - INT_db8ab08610781134”

(See the attached screenshot.)

I checked the install status of the integration at https://marketplace.zoom.us/user/installed, and found it had successfully installed (subscribed) into my zoom account.

I found some colleagues in our company encountered the same authorization issue above. I wonder if someone could tell me the additional information to solve the issue.

Thanks in advance.

Makoto Kawamura

Hi @mkawamura,

Thank you for the detailed reproduction steps and screenshot. Our team is looking into this. (ZOOM-198888).

Thanks,
Will

Hi @mkawamura,

Our team is working on resolving this issue, and it will be fixed in our next release.

Thanks!
Will

Hi @will.zoom,

Thank your for your dedication.

I look forward to seeing the next release soon. Please keep me updated!

Thanks.
Makoto Kawamura

Happy to help, @mkawamura!

Stay tuned to our Changelog to know when this fix is release.

Thanks,
Will

1 Like