Authentication fails with SDK Key and SDK Secret

When authenticating using a valid SDK Key and SDK Secret (acquired from Zoom) after initializing the MobileRTC SDK, for some reason, I get an MobileRTCAuthError_KeyOrSecretWrong error.

Which version?

To Reproduce(If applicable)

let context = MobileRTCSDKInitContext()
context.domain = ""
context.enableLog = true
context.locale = .default
context.appGroupId = ""
let initSuccess = MobileRTC.shared().initialize(context)
if initSuccess, let authService = MobileRTC.shared().getAuthService() {
    authService.delegate = self
    authService.clientKey = "<MY SDK KEY>"
    authService.clientSecret = "<MY SDK SECRET>"
extension AppDelegate: MobileRTCAuthDelegate {
    func onMobileRTCAuthReturn(_ returnValue: MobileRTCAuthError) {
        print("onMobileRTCAuthReturn: \(returnValue) \(MobileRTC.shared().getAuthService()?.isLoggedIn() ?? false)")

Attached is a screenshot of the Zoom web interface from where I fetch my SDK credentials (blacked out sensitive information)

Smartphone (please complete the following information):

  • Device: iPhone 10
  • OS: iOS 13.0
  • Version 13.0

Additional context
I also tried regenerating the SDK Key as well as using a JWT Token to authenticate but those failed as well.

Hi ar3396,

Thanks for the post. Your code looks good. Please try to deactivate your SDK app on Marketplace and then re-activate it and see if it helps.


Hi Carson, I tried out your suggestion. The issue remains after deactivating and reactivating.

Hi ar3396,

I have forwarded this to the engineering team and will get back to you shortly. Thanks!

1 Like