Error when stopping audio share

Hi, I am using StartSharePureComputerAudio() to share audio from my PC. It works correcly and returns no error. But when I want to stop sharing, I call StopShare() but the share is not stopped and I receive “SDKERR_WRONG_USEAGE” error.
Any idea about the cause?

Thanks!

Sorry for bumping this, but it is a blocking issue for my product. I need to stop audio sharing but I don’t know why it’s not working.

Hi bragma,

Thanks for the post and pardon the late response. I have forwarded this question to the engineering team for further investigation and will provide an update as soon as I heard back from them. Will provide update shortly.

Thanks!

1 Like

Hi bragma,

Thanks for the post. The engineering team was able to identify an issue with this interface and we will fix this issue in the next release. Pardon the inconvenience caused by this.

Thanks!

Thanks for checking this. Is it possible to know when the release will be? It is a blocking issue for us and we’ll need to have it fixed as soon as possible. Thanks!

Hi @bragma,

Thanks for the reply. I do not have an ETA at the moment. Please follow our Github repo: https://github.com/zoom/zoom-sdk-windows for any updates;

Thanks!

Ok. If the problem is in the C# wrapper we can try to fix it, but there is nothing we can do in the SDK. Do you know if the problem is in the windows SDK or the wrapper?

Another question: What’s the purpose of EnableShareComputerSound(bool)? Can I use it as a workaround to stop audio sharing?

Hi @bragma,

Thanks for the reply. I have forwarded your questions to the engineering team and will provide an update as soon as I heard back from them. In the meantime, here is the definition of the interface EnableShareComputerSound for your reference:

/// \brief Set to enable or disable the audio when sharing.
	/// \param bEnable TRUE indicates to enable. FALSE not.
	/// \return If the function succeeds, the return value is SDKErr_Success.
	///Otherwise failed. To get extended error information, see \link SDKError \endlink enum.
	/// \remarks Valid for both ZOOM style and user custom interface mode.
	virtual SDKError EnableShareComputerSound(bool bEnable) = 0;

So this should work as a workaround.
Hope this helps. Thanks!

1 Like

Great, I’ll start audio share and use this call to start/stop audio. Nice workaround.

Sorry to bother you again @Carson_Chen, but this does not seem to work too. When I want to stop sending audio I call EnableShareComputerSound(false), I get a success response but the audio is still sent.