Events Webhooks not called

The API we declared in the “Event Subscription” (for Event Updates) is never being called.

We do not see any errors, simply that our API is not getting called by any Zoom Webhooks

Which App Type (OAuth / Chatbot / JWT / Webhook)?

Which Endpoint/s?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Create the OAuth App & get it published
  2. Add “Event Subscriptions” for meeting update and provide a valid API on our backend
  3. Create & Update meetings
  4. Nothing happens

Additional context

  • We made sure that this issue isn’t due to an outdated version of our app installed on out test accounts. After uninstalling / reinstalling, the issue is still occurring.

  • Our backend endpoint seems to be working normally when hit via Postman.

  • Adding an event subscription to to the same API has the same result.

  • Backend endpoint is reverse proxied through an edge server to a zoom handler service. We log every stage here, and do not see any requests in our logs.

Hey @clement,

To debug this issue easier, can you try creating a Webhook-only app type, and checking the respective events you would like to receive, fill in your endpoint url, and then make sure your webhook app is activated.

Then create and update the meeting, and check the Webhook logs here to see if it was sent.

Let me know if you see any logs.


Thanks @tommy will try this and get back

1 Like

@tommy so creating a Webhook-only app type works, webhooks events are triggered and appear in the logs page.
But however, according to the documentation in the page you provided:

Webhook-only apps allow you to receive near real-time information about specific events that occur in your Zoom account

What does that exactly mean, because it sounds like the webhooks will be limited to the account where the webhook app is created from ?

Our OAuth app allows any user to install our OAuth App on their Zoom account, which means that they will be different accounts. For people outside of our own account, we don’t receive webhooks, so that solution doesn’t really address our needs.

The OAuth app is what we need to use for webhooks as, unless I’m mistaken, we would receive webhooks events for any account that installed it.
How could we troubleshoot this?

Hey @clement,

Correct. I wanted you to do this so it is easier for debugging. Did those webhooks reach your server?

I know! :slight_smile:


@tommy so to answer your question, yes, the webhooks worked normally in a webhook only app, logs appeared on our backend and things ran smoothly.

How can we troubleshoot what’s going on on our OAuth app?

1 Like

Hey @clement,

What is your app name?

Make sure the user who is trying to trigger the webhooks has installed the app if it is a User Level OAuth app.


@tommy our app is ‘Cue Calendar’.
To answer your question, yes we are performing our tests with users that have installed the application via the Zoom Marketplace.

Hey @clement,

I see you have the Event webhooks configured, but it looks like you have not submitted an update request. Once you submit the update request and we approve it, you will be able to receive the webhooks for your published (production) app.