Got error: 'You have reached the maximum per-second rate limit for this API. Try again later.'

Hi Tom,
It is not happening all the time though.

What is ‘rate limits’?

Thanks.
Regards,
Selva

Hey @selva.iyyamperumal,

Keep monitoring it.

You can see our rate limits here:

https://marketplace.zoom.us/docs/api-reference/zoom-api/users/userpermission

If you call that endpoint to much, it will throw the above error.

Thanks,
Tommy

Thanks Tom.

Please let us know what is ‘too much’ here. The error says:
‘reached the maximum per-second rate limit’

I have checked our logs and we never called this API multiple times within a sec.

Thanks.
Regards,
Selva

Hi Tom,
The doc says 10req/sec (https://marketplace.zoom.us/docs/api-reference/rate-limits).
We don’t call this API 10 times/sec. Please clarify.

Thanks.
Regards,
Selva

Hey @selva.iyyamperumal,

Does your app call any of these APIs more then 10 times/sec:

Screen Shot 2020-03-17 at 1.25.00 PM

Note the /v2/*

Thanks,
Tommy

wroy@ecp-careers.com
Any update Tom? Please let us know

Hey @selva.iyyamperumal,

When we checked our logs we saw that you were not hitting the rate limits, which makes us think it is a bug on our end.

Are you still seeing the rate limit errors?

Thanks,
Tommy

1 Like

Yes Tom.
2020-03-31 05:21:57 -07:00: CREATE …
2020-03-31 05:21:57 -07:00: Request to get the user permissions info
2020-03-31 05:21:57 -07:00: Body: { code: 429,
2020-03-31 05:21:57 -07:00: message: ‘You have reached the maximum per-second rate limit for this API. Try again later.’ }

seeing it a lot today. If you need all occurrence details, please let me know.

Thanks for details @selva.iyyamperumal,

We are looking into it and will get back to you. (ZOOM-145150)

Thanks,
Tommy

Hi
I have same issue (31.03.2020, 22:30 CET). It appeared several times during 10 minutes. I’ve executed 1 request per 10 seconds, but still I’ve got (randomly) “{“code”:429,“message”:“You have reached the maximum per-second rate limit for this API. Try again later.”}”

Hey @gregory,

Can you let us know if this happens to you again. We are seeing this issue be one off most of the time.

Thanks,
Tommy

Hi,
I’ve tested it right now (1.04.2020, 10:00 CET) and issue still exists. For +/- 10-20% cases

Gregory

Hey @gregory,

Things I need from you to investigate:

  1. Name of the App
  2. Account ID or Account # of the developer who made the app
  3. Which endpoints are returning the rate limit error and when

Thanks,
Tommy

Hello @tommy
I’m facing the same error. I’m using zoom plugin for wordpress and the issue is that after a certain time and requests there is a generation of a wordpress error from Zoom
The huge issue is that If I update at that specific moment, Zoom creates a new meeting automatically and that is confusing as we will have many registrations from different participants. How will we handle this if they have registered for 10 different meetings as wordpress creates new meeting ID’s automatically as per wrong interaction with zoom…

Hey @j.houdremont,

Are you the developer of the wordpress integration? Please share the link to the integration.

Thanks,
Tommy

Hi Tommy
it was Creating Meeting rest api endpoint, nevertheless it works correctly right now. No more issues occured.

Reagrds
Gregory

1 Like

Happy to hear it is working now! :slight_smile:

Thanks,
Tommy

Hi, we’re seeing this error intermittently right now, and we’re definitely not coming close to 10 calls/second. This is for the Groups.io app. We call /v2/users/me/meetings and /v2/users/me/settings.

Hey @markf,

Are you on a free basic Zoom account? If so, your app will only have 1 request per second rate limits.

Thanks,
Tommy

For us the error is mostly gone since Apr 12. Occurs very rarely now. Doing less than 1 request per second.

Are you on a free basic Zoom account? If so, your app will only have 1 request per second rate limits.

It doesn’t seem to be covered by docs.