InstantMeeting with No Password


I’m trying to start a meeting and passing back the credentials to my backend. For now I’m using a hardcoded user to be able to create a meeting from the Android SDK. I’m able to both join or create (instant) meeting, the problem is there is no way to get the password, I realize this might be not ideal but would like to know if it’s possible, otherwise what is the proposed method for other users to join the meeting I create from the SDK without having to explicitly get the password by other means?

Which version?
Android SDK - 4.4.55968.0904 (According to getVersion(Context))

Hi oscar.rene1989,

Thanks for the post. If you would like to get the meeting password, here are the steps:

  1. Call the InMeetingService.getCurrentMeetingID(
  2. Pass the Meeting ID to PreMeetingService.getMeetingItemByUniqueId(
  3. You will get a MeetingItem object that contains the meeting info, then call getPassword( to get the meeting password.

Hope this helps. Thanks!

Thanks for the response, my issue now is that getCurrentMeetingID returns a String that doesn’t seem like it can be parsed as a number (HeReSCe1Tqub4BbuGvL0tQ==) and the getMeetingItemByUniqueId takes a long, that I even tried passing the meeting number with no success. Do I need to do something else before?

Hi oscar.rene1989,

Thanks for the reply. I found a solution that could make everything easier, you can disable the password on the account level, you can login your zoom account on the web portal(, and change the following setting to off:

Once you disable this, then you do not need to worry about the password when start an instant meeting.

Hope this helps. Thanks!

That worked pretty well, thank you!

1 Like

Glad to hear that works. Let me know if any other questions. Happy Zooming! :smiley:

1 Like

cau you help me to initialized SDK need help please

Hi zhpszoom,

Thanks for the reply. If you need guidance for the SDK initialization, you may refer to the doc:

Hope this helps. Thanks!

Hey i could not modify on the settings page, it says “The administrator has locked this setting and you cannot change it”. Since I am the admin of this account how on the world am i supposed to modify it ?

Hi @codelogicapp,

You could disable the password in the user-level setting. If you are the admin of the account, but not be able to modify the account-level setting, then you might need to contact Zoom support at and have one of the Zoom experts to help on your account.