Invalid parameter - webSDK 1.7.6

Michael, can you please update this thread when it is fixed? Thanks.

I just installed the SDK following the process described at https://marketplace.zoom.us/docs/sdk/native-sdks/web
I also get the error: “Api key length error, must 22”
This looks like it was written by someone who does not speak English well and was written when your API key character limit was 22 characters.
My API Key is 36 characters in length.
Here is an image of my debugger showing the error in your code:


I know a fix was promised a few days ago, but this looks like an old bug.
Time until fix?

Kind Regards, Garry.

By the way, your CDN version of this sample does also not work but is throwing this error:

browser console log:
sockjs.js:1606 GET http://localhost:9999/sockjs-node/info?t=1587708040981 net::ERR_CONNECTION_REFUSED

node.js:
[2020-04-24T06:03:20.294Z] “GET /sockjs-node/info?t=1587708199986” Error (404): “Not found”

Hey @garry, @wizard_files3, @trevorgreenleaf, @nick1, @dorairajs,

The invalid parameter issue will be fixed in the upcoming 1.7.7 release this weekend.

Thanks,
Tommy

Thank you for the response @tommy.

In my case, the error was because I was using SDK credentials instead of JWT credentials.

It worked like a charm after using my JWT credentials.

WebSDK uses JWT credentials as mentioned in the link below.

3 Likes

@dorairajs
You know I love you so much?

Thanks for the tip!

1 Like

Awesome! this worked :+1:

1 Like

Hey all … I’m getting an even weirder error.

participantId length > 16

Screen Shot 2020-04-28 at 12.08.17 pm

I’m using the same user id as always (yesterday it worked fine) … although if I remove it altogether it works and the meeting starts. Does that mean that it is using the userEmail as the identifier of the user account and no longer the participantId

 ZoomMtg.init({
                        debug: false,
                        leaveUrl: 'https://zoom.us',
                        disableInvite: true,
                        showMeetingHeader: false,
                        isLockBottom: false,
                        isShowJoiningErrorDialog: false,
                        success: function(res){
                            ZoomMtg.join({
                                meetingNumber: that.meetingNumber,
                                userName: userDetails.firstName,
                                userEmail: userDetails.email,
                                passWord: that.meetingPassword,
                                apiKey: that.apiKey,
                                signature: that.meetingSignature,
                                participantId: userDetails.zoomID,
                                success: function(res){console.log(res)},
                                error: function(res){
                                    if(res.errorCode > 0){
                                        alert(res.errorMessage);
                                    }
                                    return false;
                                }
                            });
                        },
                        error: function(res){
                            console.log('some error');
                        }
                    });

Cheers …

Hey @dorairajs,

Correct! :slight_smile: Thanks for sharing your solution!

Glad it is working for you now @Christian, @chris.addams :slight_smile:

-Tommy

1 Like

Hey @SimoneLabianca,

The participant ID should only be a few numbers in length. What are you using for the participant ID?

Thanks,
Tommy

Hey @tommy … I was the using the Zoom User ID as the participant ID. Up until 1.7.4 it worked fine.

At this point, I am assuming the email address is enough of a unique identifier for the participant and an actual Zoom account is not necessary to participate in a meeting.

Cheers
Simone

1 Like

Hey @SimoneLabianca,

Gotcha! Yeah I agree using the userEmail instead of the participant id is the best solution here.

Thanks,
Tommy

I am still getting the below error using 1.7.8 when I tried to join the meeting. Please check.
{
errorCode: 4003
errorMessage: “participantId length > 16”
method: “join”
result: null
status: false
}

Hey @ayushp27196,

Please see my post here about the participantId:

Thanks,
Tommy

Hey @tommy I got this issue kindly guide me. How can I resolve it.

Hi @hkaleem7890,

Can you please share a screenshot of your browser console when you receive this error? Additionally, please make sure you’re on the latest version of our Web SDK.

Thanks,
Will

1 Like

Hi @will.zoom Thank you so much for your response. But I resolved my error. Thanks Again. take care

I’m glad to hear that Will resolved your issue! Feel free to reach out if you encounter any further issues or questions.

Max

Hi @MaxM,

Thank you so much for your fast response.

Kaleem

1 Like

I appreciate the appreciation. Happy Coding!

Max

1 Like