Invalid parameter - webSDK 1.7.6

Hey @nick1,

Can you share your init and join functions so I can debug? Please fill out the full post template so we can assist faster.

Thanks,
Tommy

Hi @tommy,

I have the same error. I just cloned https://github.com/zoom/sample-app-web into my laptop and tried to connect to an ongoing live meeting.

I still have a free plan.

I have created oAuth/JWT/SDK client apps in zoom. Then provided the SDK clientID and secret in this cloned repository. I cannot join to my meeting. Here is the init() from index.js file under CDN subproject.

ZoomMtg.init({
            leaveUrl: 'http://www.zoom.us',
            isSupportAV: true,
            success: function () {
                ZoomMtg.join(
                    {
                        meetingNumber: meetConfig.meetingNumber,
                        userName: meetConfig.userName,
                        signature: signature,
                        apiKey: meetConfig.apiKey,
                        passWord: meetConfig.passWord,
                        success: function(res){
                            $('#nav-tool').hide();
                            console.log('join meeting success');
                        },
                        error: function(res) {
                            console.log(res);
                        }
                    }
                );
            },
            error: function(res) {
                console.log(res);
            }
        });

This is what I see on my browser console:

{method: "join", status: false, result: null, errorMessage: "Api key length error, must 22", errorCode: 4003}

Best regards,
Jude

1 Like

Hi @nick1 @jude.niroshan11 ,

We are working on a fix for this right now, we should have the fix deployed within the next 24-48 hours.

2 Likes

all seems to be working now, its about time :grinning:

thanks guys

:’( seems like i spoke to soon, it was working properly then it just sort of bombed out on me without any errors

is everything ok with you guys ?

Hey @nick1 Did you change anything to make it work?

Thanks.

hy @dorairajs seems like i got too excited and spoke too soon :’(

it worked for a couple of testing times both on local and https://zoombackend.herokuapp.com but now it just well literally black

please guys @Michael_Purnell @tommy

Has this been fixed?

I am getting same “Invalid Parameter” error when trying to join the meeting with MeetingId and Password via a sample app provided in SDK.
Can Zoom please update this thread if this is fixed?

Michael, can you please update this thread when it is fixed? Thanks.

I just installed the SDK following the process described at https://marketplace.zoom.us/docs/sdk/native-sdks/web
I also get the error: “Api key length error, must 22”
This looks like it was written by someone who does not speak English well and was written when your API key character limit was 22 characters.
My API Key is 36 characters in length.
Here is an image of my debugger showing the error in your code:


I know a fix was promised a few days ago, but this looks like an old bug.
Time until fix?

Kind Regards, Garry.

By the way, your CDN version of this sample does also not work but is throwing this error:

browser console log:
sockjs.js:1606 GET http://localhost:9999/sockjs-node/info?t=1587708040981 net::ERR_CONNECTION_REFUSED

node.js:
[2020-04-24T06:03:20.294Z] “GET /sockjs-node/info?t=1587708199986” Error (404): “Not found”

Hey @garry, @wizard_files3, @trevorgreenleaf, @nick1, @dorairajs,

The invalid parameter issue will be fixed in the upcoming 1.7.7 release this weekend.

Thanks,
Tommy

Thank you for the response @tommy.

In my case, the error was because I was using SDK credentials instead of JWT credentials.

It worked like a charm after using my JWT credentials.

WebSDK uses JWT credentials as mentioned in the link below.

3 Likes

@dorairajs
You know I love you so much?

Thanks for the tip!

1 Like

Awesome! this worked :+1:

1 Like

Hey all … I’m getting an even weirder error.

participantId length > 16

Screen Shot 2020-04-28 at 12.08.17 pm

I’m using the same user id as always (yesterday it worked fine) … although if I remove it altogether it works and the meeting starts. Does that mean that it is using the userEmail as the identifier of the user account and no longer the participantId

 ZoomMtg.init({
                        debug: false,
                        leaveUrl: 'https://zoom.us',
                        disableInvite: true,
                        showMeetingHeader: false,
                        isLockBottom: false,
                        isShowJoiningErrorDialog: false,
                        success: function(res){
                            ZoomMtg.join({
                                meetingNumber: that.meetingNumber,
                                userName: userDetails.firstName,
                                userEmail: userDetails.email,
                                passWord: that.meetingPassword,
                                apiKey: that.apiKey,
                                signature: that.meetingSignature,
                                participantId: userDetails.zoomID,
                                success: function(res){console.log(res)},
                                error: function(res){
                                    if(res.errorCode > 0){
                                        alert(res.errorMessage);
                                    }
                                    return false;
                                }
                            });
                        },
                        error: function(res){
                            console.log('some error');
                        }
                    });

Cheers …

Hey @dorairajs,

Correct! :slight_smile: Thanks for sharing your solution!

Glad it is working for you now @Christian, @chris.addams :slight_smile:

-Tommy

1 Like

Hey @SimoneLabianca,

The participant ID should only be a few numbers in length. What are you using for the participant ID?

Thanks,
Tommy

Hey @tommy … I was the using the Zoom User ID as the participant ID. Up until 1.7.4 it worked fine.

At this point, I am assuming the email address is enough of a unique identifier for the participant and an actual Zoom account is not necessary to participate in a meeting.

Cheers
Simone

1 Like

Hey @SimoneLabianca,

Gotcha! Yeah I agree using the userEmail instead of the participant id is the best solution here.

Thanks,
Tommy