Issue with report/meetings/{meetingId}/participants API

Hey @hidayaacademy,

We are in the process of seeing why that meeting is not returning participants. We will get back to you once we find out. (ZOOM-144482)

Thanks,
Tommy

1 Like

@tommy this morning I found another issue with related API call. That is API from step 3.

/v2/report/users/{userId}/meetings?from=2020-02-29&to=2020-03-14&page_size=100

So this report today returns almost for all meetings information without user_name and user_email.

This is how part of JSON response looks like:
{
“uuid”: “9h1Ex9t+Sw+egmTjXc+huQ==”,
“type”: 3,
“topic”: “Some topic name”,
“user_name”: “Profesor 01”,
“user_email”: “pm1@…com”,
“start_time”: “2020-03-11T17:59:46Z”,
“end_time”: “2020-03-11T19:05:18Z”,
“duration”: 66,
“total_minutes”: 1051,
“participants_count”: 24
},
{
“uuid”: “w7zWijRHRm2k2MOfsi5NHw==”,
“id”: 191204613,
“host_id”: “UAuukmo-S5mNJ0_1yTCpxA”,
“type”: 3,
“topic”: “Some topic name”,
“start_time”: “2020-03-16T18:30:22Z”,
“end_time”: “2020-03-16T19:28:54Z”,
“duration”: 59,
“total_minutes”: 1116,
“participants_count”: 30
}

If you compare first and second object in JSON response you will see that in the second there is not information about user_name and user_email but also in the second object you can see it shows id and host_id but in the first not. This is same API returns different objects in one response.

Hey @hidayaacademy,

Following up on the prior issue, it is a bug / edge case and we are working to fix the issue and fix your data.

As for the user_name and user_email issue, this most likely means the user without the user_name and user_email was not logged into Zoom when joining your meeting.

Thanks,
Tommy

Good Morning @hidayaacademy, @tommy Tommy , and all,

I have been troubleshooting an issue with the report/meetings/{meetingId}/participants API call which started up on Saturday, 3/14/2020. I’m not sure if it is related but I didn’t want to post another thread if it is related.

I have found that all my calls to this API with a “/” in the Meeting UUID are returning meeting not found. I am using double encoding within my code but tried as a regular string for testing and it still failed.

Again this just started on code that has been working for a couple months without issue.

If it is not related I will start a new thread.

Hope this helps,
Sean

Hey @sohling,

Please share your request details and the meetingUUID you are passing in so I can look into the issue.

Thanks,
Tommy

@tommy regarding issue with missing information about participants. That is not only API problem, same issue is on Zoom web application (control panel). It doesn’t show report correctly.

But when you click on this 61 link which is total number of participants it shows empty view.

Hey @hidayaacademy,

This is related to our downgraded dashboard status. Please monitor here for updates: status.zoom.us

Thanks,
Tommy

Sorry all,
(UPDATED below)
I took a look further and it appears a problem with my testing code led me to the belief that my meetings with “/” were causing the issue.

UPDATE @tommy
I have discovered that at least one meeting UUID is returning a empty set for GET /report/meetings/{meetingId}/participants (similar to hidayaacademy above). Below is the call details. Additionally, I saw one cause could be the meeting being deleted so I also tried calling GET
/report/meetings/{meetingId}
and did get back results (see below)

UUID “/5J146CST+WkPQ1jt5z8RA==”
Double encoded for the “/” “%252f5J146CST%252bWkPQ1jt5z8RA%253d%253d”

GET https://api.zoom.us/v2/report/meetings/%2f5J146CST%2bWkPQ1jt5z8RA%3d%3d/participants?page_size=30
image

GET https://api.zoom.us/v2/report/meetings/%2f5J146CST%2bWkPQ1jt5z8RA%3d%3d
image

Please let me know if you want me to open a new topic.

Thanks,
Sean

Hey @hidayaacademy,

We have fixed the data and it should work now. Please try again.

We are still investigating why this happened.

Thanks,
Tommy

1 Like

Hey @sohling, can you try again?

Thanks,
Tommy

@tommy It seems that now is working correctly.

Should I create new thread regarding issue for missing user_name and user_email. Here is my post: Issue with report/meetings/{meetingId}/participants API

You explain me that is because someone is not logged on application, but this is for zoom user. Report returns me all meetings with user information (not participants) who hosted that meeting. So basically you cannot create meeting without user_name and user_email.

1 Like

Hey @tommy,

I am still receiving an empty response for the request GET https://api.zoom.us/v2/report/meetings/%2f5J146CST%2bWkPQ1jt5z8RA%3d%3d/participants?page_size=30
The response.Content = <?xml version=\"1.0\" encoding=\"UTF-8\" standalone=\"yes\"?><page_count>0</page_count><page_size>300</page_size><total_records>0</total_records><next_page_token></next_page_token>

Thanks,
Sean

Hey @hidayaacademy,

I can address it here, thanks.

Are you saying that user is the host of the meeting?

If participants returned in that list are missing the username and email fields, it is because they are not logged into Zoom.

Please see this thread:

Thanks,
Tommy

Hey @sohling,

I will have our engineering team look to restore your data.

Thanks,
Tommy

Yes @tommy, I’m talking here about this API: https://api.zoom.us/v2/report/users/{userId}/meetings?from=2020-02-27&to=2020-03-19&page_size=100

So you see this API is returning all report meetings by the user and in this API sometimes is missing information about user_email and user_name. If I try to call this API with userId 5Dh6RG3PS9qsm8FUe963bg then I got following response.

Just to know I removed other objects and show only 3 for comparison. If you take a look you will see for all objects same host_id, but first two objects doesn’t have properties user_name and user_email like third object.

These are report meetings for only one user:

{
  "from": "2020-02-27",
  "to": "2020-03-19",
  "page_count": 1,
  "page_size": 100,
  "total_records": 23,
  "next_page_token": "",
  "meetings": [
    {
      "uuid": "XarYyqy0T+6FWcYGgB/8Jg==",
      "id": 111111111,
      "host_id": "5Dh6RG3PS9qsm8FUe963bg",
      "type": 3,
      "topic": "Some topic name",
      "start_time": "2020-03-18T17:08:27Z",
      "end_time": "2020-03-18T17:45:14Z",
      "duration": 37,
      "total_minutes": 194,
      "participants_count": 7
    },
    {
      "uuid": "1k2MU4YQS/W84OhN0PIyng==",
      "id": 111111111,
      "host_id": "5Dh6RG3PS9qsm8FUe963bg",
      "type": 3,
      "topic": "Some topic name",
      "start_time": "2020-03-18T18:20:30Z",
      "end_time": "2020-03-18T18:46:49Z",
      "duration": 27,
      "total_minutes": 139,
      "participants_count": 7
    },
    {
      "uuid": "i7YGe+tAROqrkjHpdTabLA==",
      "id": 111111111,
      "host_id": "5Dh6RG3PS9qsm8FUe963bg",
      "type": 3,
      "topic": "Some topic name",
      "user_name": "Some user name",
      "user_email": "Some user email",
      "start_time": "2020-03-18T20:00:18Z",
      "end_time": "2020-03-18T20:51:41Z",
      "duration": 52,
      "total_minutes": 528,
      "participants_count": 11
    }
  ]
}

Hey @sohling,

Please try again, it should work now.

Thanks,
Tommy

Hey @hidayaacademy,

I see thanks. I will investigate this and get back to you. (ZOOM-145431)

-Tommy

Success! Thank you @Tommy. Are these issues one offs that we will have to contact your team about going forward?

Thanks,

Sean

1 Like

Hey @sohling,

The issue should be fixed for all future meeting reports. However, for the data lost on the 16th we can recover it case by case.

Thanks,
Tommy

Great Thanks @tommy,

I will be re-enabling to find all occurrences tomorrow. I will let you know if any others come up.

Sean

1 Like