Issue with Whitelist/Redirect URL for OAuth

I made use of the “any” key for both my whitelist and redirect URLs. This was working great all through testing until I submitted the application to the marketplace. At somepoint between the submission and the reviewer testing it (the second time) I can no longer get any oauth redirect to work except the exact ‘any.[mydomain].com’ that is supposed to indicate a subdomain wildcard. I get this error:

Invalid redirect: https://test.[mydomain].com (4,700)

I’ve got an open discussion with developers@ where every 3 days I’ll get a not very helpful request - I’m guessing just to maintain the 72 hour SLA window. I don’t have any other avenues. I originally submitted my app almost a month ago and have clients that are beating down the door for access to this integration to improve the usefulness of their Zoom experience.

I’ve tried many combinations of the Whitelist/Redirect URL even attempting to abandon the ‘any’ key and use only the exact url I was trying to redirect to. Bottom line is it was working then, without any changes, it wasn’t and I’ve been waiting a week for a response as to why on top of the 3 weeks I was waiting for submission responses.

For anybody having the same issue, I heard back from developers@ shortly after posting this. The solution was to use https://[mydomain].com as the whitelist url :man_shrugging: . No other whitelist url worked for me, including an exact match of the one I was testing.

Hey @michael3,

An exact match should work. Happy to hear you got it working with your base domain.


Thanks Tommy,

The exact match did not work for me. Only the domain with no subdomain.

Do you know how the resubmissions are prioritized? It’s been a lengthy process to get to this point and its a bit frustrating to have to go all the way to the back of the line for something I had no control over.

Hey @michael3,

I just tested the subdomain and it worked, let me know if I did something different from what you were experiencing:

Happy to see if I can prioritize your app, what is the name of your app?


Thanks Tommy!

Thats exactly what I was attempting as well - just to make sure anything would work before moving back into the generic items to handle subdomains. It’s ok now with the base domain only.

The name of the app is “Continu”.

I really appreciate the assistance.

1 Like

You are welcome @michael3! :slight_smile:

I will request your app be prioritized.