Join audio by computer button and camera not working with zoom SDK 1.7.4

Hi!
When joining the meeting, the join audio by computer button remains disabled, and so the user cannot hear or be heard in the meeting. You can click on the button, but it does not react and the audio is not joined. It also appears slightly grayed out.

Also, there’s a red exclamation point on the camera, and when I click on it, I get:
Cannot detect your camera, please check the device and connection and try again
This is a laptop, so there’s nothing to check and it works fine in Zoom native. It also works fine if I open the web version directly, using the link type: https://myDomain.zoom.us/wc/join/123456789

No errors are shown in the browser console.

This happens after we updated to version 1.7.4 of the web SDK.
This is an iFrame running the web SDK. It’s running on Chrome 80.0.3987.149, running on Windows 10, updated to the latest version.

Hey @ilan1,

Are you serving your site over https?

Thanks,
Tommy

We have several development servers and one is over HTTP. Up to a few days ago all worked. Indeed, the one that doesn’t is not HTTPS. Is this a new limitation?

Thanks!

Hey @ilan1,

Interesting, we have seen others have the same issue and once they serve over https it works.

Some browsers don’t allow audio / video access unless you are serving over https.

Thanks,
Tommy

Hi there Tommy, same problem here using Chrome (both over windows and MacOs) and Safari Mobile. No Https on our zoom dev server at this moment, will get it back sometime in the coming weeks (we´re migrating servers, so when that finishes).

Also, we’re experiencing issues with Icons layout with these browsers, will test with some more and look for similar problems from other developers in the forum to share ours as well.

Thanks Tommy.

Antonio

Hey @invistart,

Yes, please use https for your dev server, it is a requirement for browsers to allow access to your mic and camera.

Please share a screenshot of the layout issues.

Thanks,
Tommy

1 Like

Well, it wasn’t a browser requirement before. It only stopped working in the last couple of weeks.
Anyhow, thanks.

You are welcome! :slight_smile:

Thanks,
Tommy

you can override this by turning off chrome flags

Can you please elaborate? How? Which?

Thanks!

Hey @ilan1,

We do not suggest modifying your default browser settings to make your browser less secure.

Sure @emr.ny, this is useful for testing, but ensure your site is secure on production.

Thanks,
Tommy

1 Like

Yes, this is for Developer Testing on Local System

1 Like

Thanks @emr.ny.

-Tommy

Hi Tommy,

I have implement zoom web sdk via iframe and it was work as prefects.
But after update to lastest version, I can not turn on the camera anymore, is it not working with iframe anymore ?

Hey @telemed,

Are there any errors being thrown in the browser console? Also make sure you are serving your site over https.

Thanks,
Tommy

Hi @tommy,

We are integrating zoom web sdk into our application and we are facing the same issue even with https. We were able to join the meeting but none of the microphone/camera button gets enabled. There are no console errors either.

We are using web sdk 1.7.8 version, running on Chrome 83, MacOS

Thanks,
Vikas

1 Like

Hi @tommy , I am working along with Vikas.

Additional information

We have set the following content security policies and headers in our server

add_header Content-Security-Policy “script-src ‘self’ ‘unsafe-inline’ ‘unsafe-eval’ https://zoom.us https://*.zoom.us; worker-src ‘self’ blob:; style-src ‘self’ ‘unsafe-inline’”;

add_header X-Frame-Options SAMEORIGIN;

add_header Referrer-Policy “no-referrer”;

add_header “X-XSS-Protection” “1; mode=block”;

add_header Strict-Transport-Security “max-age=31536000; includeSubdomains; preload”;

We also tried removing all the above headers and checked but still, the Join Audio by Computer button didn’t enable.

Thanks in advance
Harish

1 Like

Hi, @tommy We found the issue.

We had used ZoomMtg.setZoomJSLib that was causing the “Join Audio from Computer” button to not enable. Removing this resolved the issue. Now we are able to join sessions with the above-mentioned headers added.

2 Likes

Hey @vikas.pulluri,

What version of Chrome is this? I cannot reproduce this issue.

Also please see @harish.venkataraman’s solution above.

Thanks,
Tommy