No sdk credentials created

Hi, I just created a meeting SDK app, but there is NO sdk credentials created at the “App credentials” tab. I only see the development and production credentials for OAuth. see the screenshot.


We will be updating our documentation shortly.

We have recently published some changes to consolidate the different credentials (SDK and Client) into a single credentials (Client) to enhance the developer experience.

Could you try using Client ID as SDK Key, and Client Secret as SDK Secret?

The goal is to reduce the amount of credentials which the developer needs to handle

but this new behavior of the app seems to affect only newly created apps - in our case the credentials are still present

does it stay that way ?

only new apps created after 12th Jan 2023 will have single credential pair(Client ID and Client Secret)

@j.schoenemeyer for your case, you will still use SDK Key and SDK Secret to sign your JWT

1 Like

using client id as sdk key doesn’t work. when I tried to use it for the sample web app (GitHub - zoom/meetingsdk-web-sample: Zoom Meeting SDK Web Sample App), it has error saying "Api key length error, must 22/36’. and my ‘client id’ is only 21 length. I’m stuck on getting the sample app running.

debug info from the console.

  1. errorCode: 4003
  2. errorMessage: “Api key length error, must 22/36”
  3. method: “join”
  4. result: null
  5. status: false
1 Like

So following the OSX SDK example, I cannot create a valid JWT token from the Client ID and Client Secret. Is the intent to use 1 set of credentials for OAuth and JWT? Or will OAuth replace JWT?

@Daniel-Useful , @AICamp_US @j.schoenemeyer

We have identified a bug, and will be reaching out directly to you for the fix.


This will still remain as is. From your screenshot, you are not affected by this.


Can you reach out to me for the fix as well? I also have no SDK credentials similar to the first screenshot.


@landandladiesapp could you share when did you create the app?

You might need to fill in the fields (description, email, etc…) before the sdk key shows.

@chunsiong.tan I created the app on 1/16/2023. I just tried filling in the details but still no SDK key shows up.

Please i have issues with my zoom sdk. The sdk key and secrete were not showing on the app credential again. But the live class platform that i built with zoom sdk requires the sdk key and sdk secrete to create a new user. I used the client ID as sdk key and Client secrete as sdk token but it still dont work

here are the new infos (February 12, 2023) for the changes of the SDK credentials

now it is possible to create more than one Meeting SDK App - perhaps you should try this new option and create a new one

could you share the code on

  • how you are generating the signature
  • methods / api you calling to create user?

Thanks for your kind response. I will check and respond to you soon

just update on this. I created a new meet sdk app. it still does NOT show the “sdk key”. but the client id is 22 length now (previously was 21 length). I used the client id as sdk key, and it works.

1 Like

Can you please work me through the step by step process of how you were able to use Client ID instead of sdk key ?

Dear Shun,
Here is the code that fetches my user credential freom the data base

require_once ‘vendor/autoload.php’;
require_once “class-db.php”;
$conx = mysqli_connect($host, $db_user, $pwd,$db_name);
$user_id = $_SESSION[‘uid’];
$select_client = "SELECT * FROM zoom_client_tbl WHERE user_id = ‘$user_id’ ";
$run_client = mysqli_query($conx, $select_client);
$row_client_det = mysqli_fetch_object($run_client);

$client_id = $row_client_det->client_id;
$client_secret = $row_client_det->client_secret;

// define(‘CLIENT_ID’, ‘redacted’);
// define(‘CLIENT_SECRET’, ‘redacted’);

define(‘CLIENT_ID’, $client_id);
define(‘CLIENT_SECRET’, $client_secret);

define(‘REDIRECT_URI’, ‘my callback url is here’);

I am generating the credentials directly from zoom market place and then inserting it to my mysqli database

@omotehinsedelecaleb how are you generating the JWT token?