SDK 1.7.9 - Recaptcha feature documentation

UPDATE: I have inconsistently got this working on Firefox as Guest. Sometimes it works, others not. Does not work in Chrome incognito mode. This is my sandbox attribute on my iframe.

 sandbox="allow-forms allow-scripts allow-same-origin allow-popups allow-modals"

@tommy @Michael_Purnell … 1.7.10 still doesn’t work. Still broken code is released. Still no solution to the damn recaptcha functionality you guys unnecessarily added. This incompetency is costing our business thousands of dollars due to delayed releases. I am the CTO for our company, and I am not risking our business due to third party broken code. Unfortunately, we don’t have the option of changing providers as we already pay a great deal to Zoom for our account.

I applied for the opt-out of the recaptcha, but have no idea when that will take place. I used our Company Account number. I hope I wasn’t supposed to use a specific user account number as that would be disastrous given we intend to create hundreds of them.

It took you guys 11 days to add a character to a regular expression and fixed something that was not broken in previous releases, but got broken in subsequent releases.

Please, please, please, please, please, please, please, please, please, please, please, please, please, please, please, please, please, please, please prioritise removing this broken, useless, unnecessary reCaptcha functionality, or if it really must be kept in, give us an option to not require it with our integrations.

The screenshots attached show it is still broken on a local dev machine with a valid SSL certificate and no incognito mode. The host of the meeting is on Chrome (normal window) and the guest (which is broken) is on Firefox.

1 Like

We understand your concerns about the current issues with the WebSDK. However, please be advised, that the use of vulgar language on the forum is not welcomed.
We strive to provide a community experience that is welcoming to everyone. Please make sure to follow our guidelines which state that titles, posts, links, etc, should be safe for “family and friends”.

With that in mind, @tommy has posted the link to opt-out of the reCaptcha feature. If you filled it out, our team will be removing the reCaptcha feature from your account this week so that you can continue developing.

Thank you for your patience.

@Michael_Purnell … sorry … what vulgar language? The only two words that may have any inclination of being harsh are “incompetency” and (removed) Neither of which can in any way shape or form be interpreted as “vulgar”.

I have attached a screenshot of the Oxford Dictionary definition of the word “damn” to prove my point as well as indicate which version of the word I was using. I used it in adjective form to further express my frustration at the situation.

Screenshot Removed

As for incompetency, if offence was taken by its use, I apologise, but you really need to put yourself in our shoes. Since 1.7.7 we’ve been dealing with system-breaking bugs introduced with each new release, culminating with this recaptcha tech. For commercial usages that equates to a lot of money in potentially lost business, not to mention developer time trying to find solutions.

I’ll wait to know when and if the recaptcha is removed from our account before continuing development.

Thank you.

@tommy - Well, another complaint from me!. I have to submit this for multiple customers. The google form requires login and only allows one submission. Sigh.

1 Like

When you say to send my application Domain name , what do are you reffering , acttualy?

Please let us turn reCaptcha off. Staying on 1.7.8 as long as possible.


We are managing many customer account. We can fil the form and white list for few. We cannot do this for all customers. Please give a hotfix where we can pass this as query parameter to disable or account level setting.
It does not work at all in iPhone and iPad.
Fix to feature which are broken cannot take days. Please act on it.

If your application is accessible through the following URL, i refers to

I got it now.

I am still doing test
through http//:localhost then I will move it to http//

Please help. Thank you

When can we expect the opt-out to happen? We too are experiencing same issues as @SimoneLabianca with 3110 errors although app is running on port 80. Error message is not helpful at all and just contains url “” and message “Fail to join the meeting”

Hello everyone.
I have a problem with captcha on zoomsdk.The problem is captcha doesn’t appear and it stcks rigth there. I think there is no problem with init and join. What should i do?

/**/localJsonpCallback({status: false, errorCode: 3110, errorMessage: “”, result: null})
errorCode: 3110
errorMessage: “”
result: null
status: false
Screen Shot 2020-07-16 at 11.02.22 AM

Hey @tselmeg, @alibek, @dodigerman2, @nvivot, @Seethaprasad_Mandike, @bmilburn, @mb_j, @SimoneLabianca,

If you would like us to disable recaptcha for your Web SDK please fill out this form:

If you are having other issues, please post a new topic in #web-sdk and fill out the post template so we have enough info to assist.

Thanks for your patience,

The Web SDK is broken and unusable for us at this point. Again. Users are getting hit with a re-captcha message and nothing happens when they click the button.

Looks like it’s back to 1.7.7 until this is fixed. The things I would do for a Web SDK release that fixes our issues without breaking something else entirely. We have a school starting interviews next week, and many, many more starting in a couple of months and I’m getting more and more concerned.

i filled up this form two days ago …though still recaptcha button is popping out there . How many days will it going to disable the feature on your side ?

thanks for your message, @tommy. I’ve filled out the form but never heard from you. Thus my original question still stands: when can we expect the opt-out to happen ?

Hey there @tommy,

What’s the ETA for opting out? Filled in the form a few days ago and I still have the Captcha…

Also, can you let us know:

_ What’s the rationale behind forcing us to using it (where is the product idea coming from? Talking to users?)
_ Seeing the backlash, is it foreseeable in the near future to have it entirely removed? (What’s the point of protecting meetings with password, etc if users have to get negative friction with a pop-up to click before actually joining a meeting?)


Hey @Alex_C, @alibek, @gautam.singh, @sales1,

We sent out another batch of disabled recaptcha notifications last night. Did you get an email? Recaptcha should be disabled for your Web SDK if you filled out the form.


Hey Tommy,

Thanks for the follow-up, however I did not received an email from Zoom and after setting up a new webinar, the Recaptcha is still present on our account…

Any chance it can be looked into?


As others have stated, we too have a large number of clients using the SDK who are stuck at 1.7.7 which has audio issues. It’s incredibly impractical to have such a large number of people request this to be disabled because you introduced a feature that doesn’t work and wasn’t really necessary.

Nobody wants to fight a CAPTCHA and argue with Google over where it is poorly detecting the crosswalks for 5 minutes straight when they’re already late to a conference call/meeting.

We desperately need a fully functional release of the SDK that doesn’t break anything. Can 1.7.11 focus on just fixing the stuff that’s broken and an option to disable the CAPTCHA on Init()?

At the very least this should be an option in the account administration portal, not a google form.

I have mentioned my licensed account email in the form and expecting that Recaptcha will get disable for all the participants who attend my meetings … am I right in saying?