Starting meeting using personalised zak token for the user asking for credentials

Using this template helps us debug your issues more effectively :slight_smile:

Since sometimes we have multiple co-hosts along with the host, i tried to get zak token for each hosts using this API.

Later tried to replace zak toke from start url with each of the host specific zak tokens, but that start url is asking for credentials to login.

PS: Normal start url works as expected.

If you are a meeting host sign in to start the meeting.

Which App Type (OAuth / Chatbot / JWT / Webhook)?

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Created zoom meeting with create zoom meeting API.
  2. Called user token API →
    to retrieve user spcific zak tokens.
  3. Replaced user-specific zak tokens with start URL’s original zak token.

Screenshots (If applicable)

Hi, @malvika.ite,

Welcome to the Developer Forum – happy to help. Can you verify if type =zak is specified in the body of the request?

Screen Shot 2022-01-19 at 6.38.50 PM


Hi Donte
Thanks for reaching out. type =zak is indeed there. But the problem is still there.

Just test on my end and can confirm that appending the zak token to the URL is working as expected. Can you test again and let me know the result? Here is what my URL looked like:{{ZAK token returned via Get a User Token Res}}

                          or{{ZAK token returned via Get a User Token Res}}

Let me know if you have any questions about this.


I am doing exactly like this. Also tried several times, but doesn’t work.

Thanks for your reply, @malvika.ite! Can you try adding type=zak as a param value instead of including it in the request body? (i.e

Then append that value to the URL like so :{{ZAK token returned via Get a User Token Res}}

To rule out a caching issue, please try to join using a private browser. Let me know if this helps.


Hi @donte.zoom Adding type=zak as param value worked like a charm!
So, now just asking out of curiosity why it didn’t work by adding it to the request body? I think in the API doc it’s added in the request body right?

Hi @donte.zoom
Apparently, i found another problem."
If one host has started the meeting and ended it, another co-host using zak token can not start the meeting. Even though the former host has ended the meeting.
It says, You cannot start the meeting meeting id because it is hosted by another user.

Technically it should still one, one host as internet connection for example, co-host should be able to start the meeting again.


I have a similar issue:

I’m getting the Zak token with such links: users/USERID/token?ttl=50000000&type=zak

(I’m using the biggest ttl possible, to have the limit of one year as explained in this link:

I’m then connecting to Error - Zoom
But it’s stopped working after few days, and I have to regenerate the Token again and again…

Please advise


The scenario described seems different from this topic. Can you open a new topic for this?



Thank you for sharing this edge case! I want to learn more about this behavior, can you share the exact steps to reproduce it? Once provided, I will work to reproduce it and create a bug ticket if necessary.


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.