Update meeting status not working

Hey @pedro.zumpano,

If it is an instant meeting, it will always say waiting unless it is in progress.

Thanks,
Tommy

Hey @trongtin6495,

Are you using your personal meeting ID for scheduled meetings?

Thanks,
Tommy

@tommy
You mean user ID? I use this API to create scheduled meeting /users/{userId}/meetings and meeting type is set to 2.

Hey @trongtin6495,

I mean personal meeting ID.

image

Let me know if you are using it for scheduled meetings.

Thanks,
Tommy

@tommy

No, I’m not using it.

Hey @trongtin6495,

Can you share your request body when creating the meeting so I can try to reproduce the issue?

Thanks,
Tommy

hy Toomy,
same thing here.
I create a type 2 meeting. After meeting is ended, status still continue in waitting value

1 Like

Hey @dlrmartin,

Can you share your request body when creating the meeting so I can try to reproduce the issue?

Thanks,
Tommy

for sure;
C#
Create:
Meeting = _ZoomPOST.MeetingAdd(New MeetingModel With {
.duration = 60,
.type = MeetingModel.MeetingType.ScheduledMeeting,
.start_time = FechaHora.ToString(“yyyy-MM-ddTHH:mm:ss”),
.topic = Topico,
.timezone = “America/Argentina/Buenos_Aires”
})

after finish de meeting
Get:
RestRequest request = new RestRequest(“Meetings/” + meetingID, Method.GET);
request.AddHeader(“authorization”, token);
IRestResponse<List> response = client.Execute<List>(request);
MeetingModel meet = Newtonsoft.Json.JsonConvert.DeserializeObject(response.Content);
return meet;

and status not changed to finished. continue waitting

1 Like

Hey @dlrmartin,

Can you share the JSON you instead of the code so I can test through postman?

Thanks,
Tommy

Hey Tommy, I too have encountered the same problem.
I created a meeting through the App, then via API call I try to update the status, response status 204 but the field has not been updated.

Hello Tommy , I have the sam issue I did create for meeting using this api
https://api.zoom.us/v2/users/:userId/meetings

When I trying to Update meeting status this the result

But The meeting status still waiting untill it updated using update status api

How can I do fixing for this problem and I have another question, can i do change for the meeting status using this api

https://api.zoom.us/v2/meetings/:meetingId

Fox example I need to change meeting status from waiting to started how I can do that ?

@tommy any Updates ?

I want to know, why after I did end for meeting , the status goes back to “waiting”?

Hey @aya, @giulio.cristiani,

Please see my post here for an explanation:

Thanks,
Tommy

I’m also facing the same issue. While creating zoom meeting via API, the type has been set to 2 and upon ending the meeting, either manually using End for all or via API, the status is updated to waiting not finished. Why is that?

Hey @tech3,

Are you using your personal meeting ID for the meeting?

Thanks,
Tommy

Hey @tommy,

No we don’t personal meeting ID for the meeting. The meeting is been created via API and the meeting ID generates randomly.

Hey @tech3,

Can you share the request body and response body JSON when creating the meeting so I can attempt to reproduce the issue?

Thanks,
Tommy

@tommy here is the request body array of creating a meeting:

    Array
    (
        [meetingTopic] => On Demand
        [meetingType] => 2
        [email] => bryan@wahana.pt
        [consId] => 3597
        [duration] => 10
        [usertype] => 2
        [capacity] => 7
        [optionAudio] => both
        [meeting_password] => 447977
        [meeting_start_time] => 2020-08-04 12:41:56
        [option_jbh] =>
        [userId] => ujCQgYy7TaK4N_s6juQA6w
    )

And response JSON:

{“uuid”:“QcvbWkhsSvaRaIqE/RIAXg==”,“id”:92200730530,“host_id”:“ujCQgYy7TaK4N_s6juQA6w”,“topic”:“On Demand”,“type”:2,“status”:“waiting”,“start_time”:“2020-08-04T12:41:56Z”,“duration”:10,“timezone”:“America/Los_Angeles”,“created_at”:“2020-08-04T12:41:56Z”,“start_url”:“https://f2fhealth.zoom.us/s/92200730530?zak=eyJ6bV9za20iOiJ6bV9vMm0iLCJhbGciOiJIUzI1NiIsInR5cCI6IkpXVCJ9.eyJhdWQiOiJjbGllbnQiLCJ1aWQiOiJ1akNRZ1l5N1RhSzROX3M2anVRQTZ3IiwiaXNzIjoid2ViIiwic3R5Ijo5OSwid2NkIjoiYXcxIiwiY2x0IjowLCJzdGsiOiJzSG5LUnZxNzRHTkNFTml5M0s0bW9JY3k1bnVrMFlvamJpdUNITFVqb1BzLkJnVVlhMjB5TkhWNmRGSmlRa2ROTjNVeFZteEpPSFpaWnowOUFBQU1NME5DUVhWdmFWbFRNM005QUFOaGR6RSIsImV4cCI6MTYwNDMyMDkxNiwiaWF0IjoxNTk2NTQ0OTE2LCJhaWQiOiJOTXpYTkJUSFRpLWpuZTRGVGlkXzRnIiwiY2lkIjoiIn0.rfBXQLYCiiKVruK1tGms4mjjRnRqqGAG8uMCfHnxiHo",“join_url”:“https://f2fhealth.zoom.us/j/92200730530?pwd=RkdpL2xUTmREbkFad0FkSW5Bd25iQT09”,“password”:“447977”,“h323_password”:“447977”,“pstn_password”:“447977”,“encrypted_password”:“RkdpL2xUTmREbkFad0FkSW5Bd25iQT09”,“settings”:{“host_video”:false,“participant_video”:false,“cn_meeting”:false,“in_meeting”:false,“join_before_host”:false,“mute_upon_entry”:false,“watermark”:false,“use_pmi”:false,“approval_type”:2,“audio”:“both”,“auto_recording”:“none”,“enforce_login”:false,“enforce_login_domains”:"",“alternative_hosts”:"",“close_registration”:false,“registrants_confirmation_email”:true,“waiting_room”:false,“request_permission_to_unmute_participants”:false,“global_dial_in_countries”:[“US”],“global_dial_in_numbers”:[{“country_name”:“US”,“number”:"+1 6468769923”,“type”:“toll”,“country”:“US”},{“country_name”:“US”,“number”:"+1 3017158592",“type”:“toll”,“country”:“US”},{“country_name”:“US”,“number”:"+1 3126266799",“type”:“toll”,“country”:“US”},{“country_name”:“US”,“number”:"+1 6699006833",“type”:“toll”,“country”:“US”},{“country_name”:“US”,“number”:"+1 2532158782",“type”:“toll”,“country”:“US”},{“country_name”:“US”,“number”:"+1 3462487799",“type”:“toll”,“country”:“US”}],“registrants_email_notification”:true,“meeting_authentication”:false}}