Webhook Not Working

Hey @jimig,

There are still some log service issues which may impact some webhook notifications.

We are working on a fix to this issue asap.

Thanks,
Tommy

The participant hooks were working yesterday, but stopped working today.

I also didn’t get notifications for “Meeting Registration has been created” event. Is it because of some issues at your end?

I am consistently getting meeting started and ended events.

@leenasn I am also not receiving webhooks for meeting recording completed - I imagine because of the pandemic, Zoom is under quite a heavy load.

Hey @MarkWalsh, and @leenasn,

We will look into the webhook issues. Can you share which webhooks aren’t working and the meetingIDs that go along with them?

Thanks,
Tommy

@tommy please see 388-329-881

We only got meeting.started event and missed participant events

Hey @jimig,

Which specific participant events did you not get?

Thanks,
Tommy

Hello,

I unfortunately cannot share any Meeting IDs as it’s our clients who are recording meetings and we have no visibility of these Ids

Hi Tommy,

We missed participant joined and left

Thanks @MarkWalsh, and @jimig,

We are looking into the issues and will get back to you.

-Tommy

Hi Tommy, are things back to normal with on time delivery now?
We are not seeing any further issues but want to be sure.

Hey @jimig,

Yes webhooks should be back to normal.

Thanks,
Tommy

Webinars webhooks are working for some apps but for not for others.
its not working for appId: B_T04cOaSN-bccKGvZOv2Q

Hey @nitin,

Which Webinar webhooks are not sending? Please private message me the webinarIDs.

Thanks,
Tommy

Hi Tommy!

Meetings webhooks are not working.
I enabled webhooks for my new app 1 hour ago.
My app still in active development phase so I can’t see Call Logs in Zoom App Dashboard

AppId: 5rzV1qhgTxu8Q2r9lxftWg
MeetingID: 886 1346 9710
ParticipantID: 158450

Hey @s.kozlov9242,

What is the name of your app? Make sure to follow the steps here.

Thanks,
Tommy

@tommy I’m also having problems with webhook delivery right now, though this is my first time ever setting it up. This is on an OAuth app.

I’ve followed the steps in the above link, don’t see any outages on Zoom Status and my endpoint is returning 200 OK.

I’ve subscribed to 6 events, including:

  • Start Meeting
  • End Meeting
  • Meeting has been created
  • All Recordings have completed
  • Recording Started
  • Recording Stopped

These are the scopes I have enabled on the OAuth App:

My (test app) client ID is TUl9f2r_S6OpdsnZaWkUtA. I can successfully send it a POST request at the URL I’ve specified on the Event Notifications panel, but nothing is arriving other than my test posts (and I am testing from a public endpoint, nothing that should be guarded).

I appreciate any guidance you can offer!

Hi @abernix, have you installed the app on a user account?

@michael.harrington Yes, I have installed it.

@michael.harrington (and others) — the solution for me was that — even though I already had the application installed (it appeared in the Installed Apps list which can be seen here), to uninstall the application from that page, and then reinstall it.

The only way I can explain this is that the webhook endpoint was enabled on the (test) OAuth application after the original installation of the app. Thus necessitating it be re-installed, I guess?

1 Like

Hey @abernix,

Happy to hear you got it all sorted out!

Yes, if you add scopes or webhooks to an already installed app, you will need to install it again, essentially updating to the newest version of the app, and so the user can approve the additional information being accessed. :slight_smile:

Thanks,
Tommy