Webhook Not Working

Hi Tommy,

Yes I’m sure that I’ve the OAuth app installed, and I’m sending back 204 as that page you linked says (either 200 or 204).

Still, the webhook on the OAuth app is not working. (Although other api calls like get user and create meeting are working)

I tried created a completely new OAuth app, delete the old token in my datastore, then using the new client id & secret to have the app installed. Still, the webhook is not working :frowning:

I think that the event subscription endpoint that I implemented (eg: /api/zoomwebhook) should be working, as it worked a few times for the Webhook only app.

I’d really appreciate your help on this!



Hey @yirui,

Alright we are on the right track! :slight_smile:

Can you share your endpoint url? Also I see you were trying to use the meeting.ended webhook event. We had some issues with it yesterday that have since been fixed. Can you try again?


@tommy can you share any more details on this outage?

It has caused us major issues- when did the incident start/stop?

Which webhooks were impacted?

Hi @tommy,

Oh no I was poking my brains out yesterday trying to figure out why it was not working :sweat:

Well, it seems like the meeting.end webhook worked a while this morning then stopped working again.

The last time I received a meeting.end webhook was at 12:03 PST today. Then I tested with a bunch of meetings with the meeting.end webhook, none of them received the event. Here are the call ids that didn’t receive the event if they are of any help:

  • 514535017
  • 289423926
  • 100649275
  • 951509265

As we are speaking, I just received the meeting.end webhook event for the meeting 514535017 at 12:35pm PST, but I ended that meeting around 12:05pm PST. Why there is such a long delay?

The endpoint url is: https://localhost-dot-yirui-dot-uv-beta.appspot.com/api/integrations/zoomwebhook



1 Like

Hey @jimig, @yirui,

Apologies to hear this has cause major issues.

You can see info about the delayed data here: https://status.zoom.us/

This is due to very high usage on our platform, and we are working to make sure there are no more delays in the future.


@tommy I cannot see details of webhooks affected there? We need to know the hook names .e.g meeting_ended so we know which data to patch/update.

Can you confirm the webhooks are now operational?

Hey @jimig,

The webhooks correspond with the “Dashboard data delayed” status.

We are seeing participant join webhooks, and meeting.ended webhooks affected.


@tommy I’ve been following the status and as of yesterday morning (around 0700 UTC?) I noticed that there were no open incidents.

However, we have a meeting after that time that is missing some hooks.
We an see recording, participant and started hooks missing.

See Meeting ID: 711483699

We need to know what’s going on so we can let our customers know.

Hey @jimig,

There are still some log service issues which may impact some webhook notifications.

We are working on a fix to this issue asap.


The participant hooks were working yesterday, but stopped working today.

I also didn’t get notifications for “Meeting Registration has been created” event. Is it because of some issues at your end?

I am consistently getting meeting started and ended events.

@leenasn I am also not receiving webhooks for meeting recording completed - I imagine because of the pandemic, Zoom is under quite a heavy load.

Hey @MarkWalsh, and @leenasn,

We will look into the webhook issues. Can you share which webhooks aren’t working and the meetingIDs that go along with them?


@tommy please see ***********

We only got meeting.started event and missed participant events

*This post has been edited to remove any meeting / webinar IDs

Hey @jimig,

Which specific participant events did you not get?



I unfortunately cannot share any Meeting IDs as it’s our clients who are recording meetings and we have no visibility of these Ids

Hi Tommy,

We missed participant joined and left

Thanks @MarkWalsh, and @jimig,

We are looking into the issues and will get back to you.


Hi Tommy, are things back to normal with on time delivery now?
We are not seeing any further issues but want to be sure.

Hey @jimig,

Yes webhooks should be back to normal.


Webinars webhooks are working for some apps but for not for others.
its not working for appId: B_T04cOaSN-bccKGvZOv2Q