You cannot authorize the app

Hey @mukund.waghmode, thanks for posting and using Zoom!

Try making the user who is trying to install the app an Admin in your user role settings: https://zoom.us/role

If that doesn’t work, please post a screenshot of the error so I can help debug :slight_smile:

Thanks,
Tommy

Hi @tommy,

I don’t want to change role from ‘Member’ to ‘admin’ for every user.
I am trying to get data with api call from member as well as admin.
So every user is going to connect single application that is user-level or account-level.
Member user should be able to get user specific data and Admin user should get admin specific means Report apis data.
Is there any way to make it possible this scenario?

Hey @mukund.waghmode,

Yes this is possible, but for Account Level apps, only admins can install them.

An account level app will only be installed once per each master Zoom account, where as a user level app can be installed by each individual user on your master Zoom account.

Does that make sense?

Thanks,
Tommy

Hello @tommy :slight_smile:

I added zoom to my platform (which is used by companies that have their own emails and so seperate zoom accounts), I have one client who is testing this, however when she is trying to initialise the connection she gets this error. The developer account is set up to one of my emails, do I need to publish the app before she can use it?

Thank you!

@tommy Is the connection only possible if the account used is the same as the developer account? I don’t want every user on that platform to be the admin, just the initial connection account, per company. If Zoom works for them after a phase of testing we will roll it out to our other companies that use our platform. Do I need to sign up for a reseller account instead?(Sorry, so many questions!!)
Thanks! :slight_smile:

Hey @rhtordoff,

To install your app, you will need someone with those permissions, or a Zoom admin.

Thanks,
Tommy

@tommy Has this been fixed? I’m getting the same error for ZOOM-111363

My app is currently in progress of being reviewed. This sucks to run into when the approval process takes 7+ days

We’re also facing this issue, although our app is already approved and published.

  • We’ve tried with Zoom account owners
  • We’ve tried with the owner of the Zoom app

In the console, I do see the following issue completing the following request:
https://marketplace.zoom.us/api/v1/apps/bWw6tKfhS6m6JQB49sajRA/@grant

image

Hey @pb_zoom, @josharcher,

Can you please share a screenshot of the error?

Our engineering team is aware of the issue and investigating this. While the team is yet to confirm the exact cause of error, upon initial review, they suspect the issue lies with this specific use of the state parameter. In the meantime they have advised that you revise the OAuth URL to not use a state parameter and it should resolve the authorization error.

For a quick resolution, if you still plan to use the state parameter you can try either of these options.

Option 1:
If possible please limit to using a single value in the state parameter.
https://zoom.us/oauth/authorize?response_type=code&client_id=CLIENT_ID&redirect_uri=REDIRECT_URL&state=STATE_STRING

Option 2:
Make use of the base64UrlEncode function to encode the state parameter
https://zoom.us/oauth/authorize?response_type=code&client_id=CLIENT_ID&redirect_uri=REDIRECT_URL&state=BASE64_ENCODED_STRING

The engineering team is investigating this at priority and we will keep you updated on the status. Let me know if neither of these help resolve the error you are encountering.

Thanks,
Tommy

@tommy I figured out the issue was able to resolve this by adjusting/simplifying the state parameter similar to the guidance you provided.

I can’t speak to @josharcher issue and if it’s the same; apologies if I hijacked your thread.

1 Like

Hi @tommy, I’m facing the same problem: “You cannot authorize the app” even from my own zoom account.

I have tried creating a new app draft as a workaround. Same problem persists.

I have even created a new Zoom account altogether and created a new app from there. Even that hasn’t allowed me to authorize my app!

Are there any other ways to solve the problem?

Thanks

Hey @karan7kar,

Can you please share your authroize / install url so I can debug?

Thanks,
Tommy

Happy to hear you figured out the issue @pb_zoom! :slight_smile:

Thanks,
Tommy

Hey @karan7kar,

Thanks! Can you also provide the screenshot of the error page?

Thanks,
Tommy

Does this do?

Hey @tommy any resolution or workaround for this problem?

Hey @karan7kar,

Are there any errors in the browser console?

Checkout this thread for a possible solution:

Thanks,
Tommy

Hi @tommy, I just checked: there are errors in the console (below).

They’re the same errors josharcher had in the thread you shared.

I’m not using any state parameter in the OAuth URL.

I’m facing same issue, waiting for solution sending state parameter.

Hey @jantbarco, @karan7kar,

Can you share your app names so I can investigate further?

Thanks,
Tommy