400 Error When Retrieving Account Settings via API

I was unable to retrieve my account settings through “url = https://api.zoom.us/v2/accounts/me/settings” when I try to run the python function in my local machine I was getting this error “Failed to fetch account settings. Status code: 400
Response: {“code”:4711,“message”:“Invalid access token, does not contain scopes:.”}”. For authentication, I’m utilizing the “Server-To-Server OAuth” method. I am confident that my access token is valid, as I can successfully use it to list and create users. Additionally, I have ensured that my application has the necessary scopes assigned for these operations.
Below are the scopes I have provided to my application:

|View and manage account info|
|View and manage sub accounts|

Could anyone guide me on what might be causing this error? Is there a specific scope required for accessing account settings that I might have overlooked, or could this be related to another issue?

Thank you for your assistance!

I am also facing a similar issue, I have created a account-level “Server-to-server OAuth” app and have activated all the necessary scopes that to be used but I am getting Client error: GET https://api.zoom.us/v2/accounts/<my_account_id>/settings resulted in a 400 Bad Request response: {“code”:4711,“message”:“Invalid access token, does not contain scopes:[account:read:settings:master].”}

I have already confirmed “account:read:settings:master” along with other scopes is already available in my scopes, I have already tried deactivation - activation and also have waited for almost 18 hours in thought of it might take some time to be used but still no luck.

Any help would be much appreciated.