Can't join second meeting after completing first meeting

I have an Angular SPA app. I use zoom web sdk component view and join the meeting first time it works perfectly and then I end the first meeting and when I start a second meeting without refreshing the page it doesn’t start meeting and didn’t show a meeting screen, when I reload the page join the second meeting then it works.

I have used Web SDK version 2.3.5

client = ZoomMtgEmbedded.createClient();

zoomInit() {

    let meetingSDKElement = document.getElementById('meetingSDKElement');
      debug: true,
      zoomAppRoot: meetingSDKElement,
      language: 'en-US',
      customize: {
        video: {
          isResizable: true,
          viewSizes: {
            default: {
              width: 500,
              height: 220

        meetingInfo: [

this.httpservice.Post("/encounter/meeting/joinmeeting", { MeetingID: this.appointment.MeetingId })
        .then(x => {
            sdkKey: x.Data.ZoomSettings.SdkKey,
            signature: x.Data.Signature,
            meetingNumber: x.Data.MeetingID,
            userName: x.Data.DisplayName
        }).catch(x => {

When I join the second meeting and create the Client then it returns the previous meeting object that has the previous meeting number.
client = ZoomMtgEmbedded.createClient();

  • Device: Lenovo Think Pad
  • OS: Windows 10
  • Browser: Chrome
1 Like

I facing the same problem. I have to mention that I’ve integrated Zoom with a react application. and this also happens when I use the web sdk component view

What I noticed is that this problem only happens when you end the meeting as the meeting host.

I will try to give more details below:

Let’s say that I’m starting a meeting, i’m the host, and at a given time I decide that I want to end the meeting, so I will click the ‘Leave’ button and from there I choose the ‘End Meeting for all’ option, everything goes as expected, the meeting has successfully ended.
But I realize that I want to start another meeting, so I’ll try to start a new meeting without refreshing my browser, and I can see the ‘Joining meeting…’ loading screen but that it, after the ‘Joining meeting…’ screen disappears I don’t see the meeting screen, all though I get a response from the join action without any errors and if I check Sign In - Zoom page I can see the the meeting has started.

However, if there are other people attending that meeting and I choose to assign one of those people as the new meeting Host when I decide to leave the meeting, I can successfully start a new meeting without refreshing the browser but only when I know that the meeting was ended by newly appointed host.

Which version?
Latest version: 2.4.0

1 Like

Hi Bogdan, did you happen to find any solution to this problem ? I’m also facing the same issue

Hi Mirza,

For now when I detect that the host clicked on the "End meeting for all" button, I trigger a page refresh. I don’t know if I can call this a solution, but it does the job, and I couldn’t wait, I had to solve this problem even if it annoys some users.
So I just trigger the page refresh for the users, when they click on the “End meeting for all” button.

I’m still hoping that maybe someone from the Zoom team will answer, and will help us with our problem.

OK, thanks for your response. Doing a page refresh will be my last resort. Hopefully someone from Zoom responds soon

@juma.bharadia, @mirza.hasanovic, @luca,

I believe this is related to a known issue that our Engineering team is working to address [ZOOM-372963]. I’ve shared the details about this behavior already with our team. Once more information is available, I will let you know here.

1 Like

Please inform me when this issue is resolved. @donte.zoom

I was running into this issue also using the component view in a react app. What I did until zoom fixes this issue is hide the end and leave buttons and created a custom button for ending a webinar which calls leaveMeeting. If there is only one host it will end the webinar but a new one can be started and the zoom component won’t be hidden.


Thank you for sharing your work around @jmd11!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.