Crash upon joining a meeting

I am seeing the following crash, after joining meetings, after updating to the latest version of the zoom SDK:

dlopen failed: cannot locate symbol "__emutls_get_address" referenced by "/data/app/~~jt9E1aWsCpnbFMxFnLsuVg==/"...

It appears I am getting a conflict between two libraries I am using, one being the Zoom SDK (I see this if I remove the pickFirst from packaging options):

2 files found with path 'lib/arm64-v8a/' from inputs:
 - /Users/chris/.gradle/caches/transforms-3/05c48075d903ffbc908c04da44693029/transformed/jetified-react-native-0.67.3/jni/arm64-v8a/
 - /Users/chris/.gradle/caches/transforms-3/26d25477aaab16d2fc6c550edf665205/transformed/jetified-mobilertc-
    packagingOptions {
        pickFirst 'lib/arm64-v8a/'
        pickFirst 'lib/x86/'
        pickFirst 'lib/x86_64/'
        pickFirst 'lib/armeabi-v7a/'
        pickFirst 'lib/x86_64/'
        pickFirst 'lib/arm64-v8a/'

Is there a way to ensure the correct version of the .so file is being picked? Intermittently builds seem to happen where I can join calls fine, but I don’t want to have to build several times and have to check each time if zoom calls are working.

1 Like

Hi Christopher,
Hope so you’re doing good this week, identify the library that is conflicting with the Zoom SDK and remove it from your project’s dependencies. You can do this by modifying your project’s build.gradle file or by updating the library version to a compatible one. In your packagingOptions configuration, make sure to specify the correct version of the file for the desired architecture. You can use the pickFirst directive to prioritize the correct version, ensuring it is selected during the build process. After making the necessary changes, clean your project and perform a full rebuild to ensure that the changes take effect properly. This will help ensure that the correct libraries are included and conflicts are resolved. Hope so this will work for you!
Bryce June

1 Like

I had the same error, using packagingOptions it even solved it, but only for some devices, on the xiaomi mi 11t ultra for example it didn’t work yet.


Thank you for sharing this insight with the Zoom Developer Forum!

1 Like

Specifying the version of libc++_shared was insufficient, as it caused issues with older versions of React Native. I needed to update React Native versions, an involved process, as there was an incompatibility that is fixed with newer versions of React Native.

Hi, thanks for sharing your solution, could you tell which version you updated React Native to please?

I encountered a similar error. While using packagingOptions, the issue was resolved for certain devices. However, it still persists on devices like the Xiaomi Mi 11T Ultra.

Best Regards,

Sorry for the delayed reply – Upgrading to 0.71 fixed this issue.

1 Like

hi, Donte, I have searched entire google and ZOOM docs, but in latest Zoom Meet SDK (updated March 2024 ), I can not find the “commonlib” foloder and file . Can you please help me to locate the right thread, or the file itself.
Thank You

I am getting same issue and nobody is replying to the request. I have subscribed to Business plan, seems like I should cancel the subscription before next renewal.

Jovin, as of 5.17.0 commonlib has been merged with mobilertc.

See: Zoom Meeting SDK - Android - 5.17.0

@jazzysehdev ,

Correct, please see the changed log here: