Create meeting using sdk - Angular

Description

How to create a meeting with the option of joint meeting before the host?
join_before_host:true

Hey @karthi_srv,

Have you tried calling the create meeting API?

Please provide more details about your issue so we can help.

Thanks,
Tommy

Hi @tommy

I like to disable the header

showMeetingHeader: false

But its not working

1 Like

I need to hide following option

  1. Participants
  2. … more
  3. Header (i and encryption icon on top of the meeting)

how can i do it

Hey @karthi_srv,

Please place the respective functions in your join meeting success callback. Let me know if that works. If not, please share your code snippets so I can debug,

Thanks,
Tommy

Trying the hide the header doesn’t work for me either.
Tried it in multiple places:

        ZoomMtg.init({
            debug: true,
            leaveUrl: curUrl,
            isSupportAV: true,
            isSupportChat: true,
            disableInvite: true,
            showMeetingHeader: false,
            success: function() {
                ZoomMtg.join({
                    signature: "<?php echo $signature; ?>",
                    apiKey: "<?php echo $this->api_key; ?>",
                    meetingNumber: <?php echo $this->meetingid; ?>,
                    userName: "<?php echo $userName; ?>",
                    passWord: "<?php echo $this->password; ?>",
                    userEmail: "<?php echo $this->email; ?>", 
                    success(res) {
                        ZoomMtg.showMeetingHeader({
                            show: false
                         });
                    },
                    error(res) { 
                        console.log(res);
                    }
                })
            },
            error: function() {
                console.log("init failed");
            }
        });

Hey @ativsoftware,

What version of the Web SDK are you using? Can you also please provide a screenshot of the issue?

Thanks,
Tommy

Web SDK v. 1.7.8

Screen Shot 2020-06-03 at 11.14.47 AM

Same issue here with 1.7.8 web SDK. Configured to hide meeting header as follows, yet it is still visible. The other settings (such as isSupportChat) seem to work.

    ZoomMtg.init({
        leaveUrl: '?',
        isSupportAV: true,
		isSupportChat: false,
		showMeetingHeader: false, 
		videoHeader:true,
		isLockBottom:false,
        success: function () {
          		 ZoomMtg.join(
 {
     meetingNumber: meetConfig.meetingNumber,
     userName: meetConfig.userName,
     signature: signature,
     apiKey: meetConfig.apiKey,
     userEmail: 'user-email@gmail.com',
     passWord: "",
     success: function(res){
         console.log('join meeting success');
     }
 }

);
},
error: function(res) {
console.log(res);
}
});