Curl Request for creating meeting suddenly doesn't work without changes

Using this template helps us debug your issues more effectively :slight_smile:

Description
Good Day,

I programmed our website to work with the zoom oauth api and i used curl in php to make the requests to your api,
the code for creating meeting has worked since about february however when i tried it now it no longer works but i can still get a list of meetings, get a specific meeting and edit a meeting.
This is the code i use to create a meeting

$url = ‘https://api.zoom.us/v2/users/me/meetings’;
$headers = ['Authorization:Bearer ’ . $this->session->userdata[‘zoom_auth’][‘access_token’], ‘Content-Type: application/json’];
$data = $this->curl_requests($url, $headers, ‘CREATES’, $params1);
var_dump($data)

function curl_requests($url, $headers, $method, $params) {
$ch = curl_init();
curl_setopt($ch, CURLOPT_URL, $url);
curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);
curl_setopt($ch, CURLOPT_HTTPHEADER, $headers);
curl_setopt($ch, CURLOPT_CUSTOMREQUEST, ‘POST’);
curl_setopt($ch, CURLOPT_POSTFIELDS, json_encode($params));
$result = curl_exec($ch);
if (curl_errno($ch)) {
$test = curl_error($ch);
} else {
$test = json_decode($result, true);
if (!$this->is_json($result)) {
$test = $result;
}
}
curl_close($ch);
return $test;
}

Error
My biggest problem is there is no error to signify what i actually did wrong, whenever I var_dump the result it returns null

Which App Type (OAuth / Chatbot / JWT / Webhook)?
I have been using the OAuth

Which Endpoint/s?
Knowing the API endpoint/s can help us to identify your issue faster. Please link the ones you need help/have a question with.

How To Reproduce (If applicable)
Steps to reproduce the behavior:

  1. Request URL / Headers (without credentials) / Body
  2. See error

Screenshots (If applicable)

Additional context
Add any other context about the problem here.

Hey @jcdampil23,

Thank you for reaching out to the Zoom Developer Forum. First, I’m noticing in you screenshot you have a scheduled webinar whereas the List Meetings API will only return meetings.

If that doesn’t help, can you share the API response that you’re seeing. That is, the HTTP Status and Response body that are returned?

Thanks,
Max

Ahh yes, its actually a zoom meeting so its working fine, i can curl request the meetings that were scheduled, and can also edit a chosen meeting,

the only issue is when i attempt to create a new meeting, nothing happens no error code just a null value, it also used to work before just it suddenly won’t anymorr

Hey @jcdampil23 ,

Can you please share your request body JSON that you are using when calling the Create Meeting API? This will help us reproduce the issue.

Thanks,
Tommy

ahhh sure this is what i use
image
then i json encode it in the curl request, it may be called a webinar but it is actually just a meeting

Hey @jcdampil23,

Thanks for sharing this—do you have the raw JSON after it’s encoded? It’s possible your request body could be causing the issue after you encode it.

Additionally, have you tried submitting the request in Postman, cURL, using our test request tool (under each endpoint in our docs) to see if you get the same response?

Thanks,
Will

Thank you for the idea to use Postman,
I tried to make a meeting using it and it worked, then i realized after reading the documentation for creating a meeting again, that i was inputting a string that had more than 10 characters in the password field.

So apparently the solution was to either limit the password string to 10 characters or just don’t input it and let the zoom api create one on it’s own

Thank you, sorry for wasting your time when i could have read the documentation better.

Hey @jcdampil23,

No worries, I’m glad you figured it out. And thanks for letting us know. :slight_smile:

Best,
Will