electron-sdk can not work


#1

App threw an error during load
Error: Module version mismatch. Expected 50, got 57.
at Error (native)
at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:173:20)
at Object.Module._extensions…node (module.js:583:18)
at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:173:20)
at Module.load (module.js:473:32)
at tryModuleLoad (module.js:432:12)
at Function.Module._load (module.js:424:3)
at Module.require (module.js:483:17)
at require (internal/module.js:20:19)
at init (C:\Users\49970\zoom\zoom-winsdk-electron\zoom-sdk-electron\lib\zoom_sdk.js:76:17)


#2

Hi! Thanks for using Zoom SDK. Our Electron SDK requires Node.js version 8.12.0 and if you have higher version, you will get this error message. Using Node.js 8.12.0 will resolve this problem. Thanks!