Embed zoom video to a web server

Hi @paulthies,

We don’t have a official plugin to embed Zoom into another platform. However, you use an iframe to embed our web client within an application.

Thanks

Hi,

I use the code provided to embed a scheduled webinar but am getting an error code Invalid meeting ID. (3,001)

Any help is greatly appreciated.

thanks

Hey @vitalsynergy,

What is the meeting ID you are using?

Thanks,
Tommy

1 Like

Hi Tommy ,

I used both *********** and 825227050

Thanks

Brent

*This post has been edited to remove any meeting / webinar IDs

Thanks @vitalsynergy.

Can you try removing the success. from the join url and see if that works?

<div class="iframe-container" style="overflow: hidden; padding-top: 56.25%; position: relative;">
    	<iframe allow="microphone; camera" style="border: 0; height: 100%; left: 0; position: absolute; top: 0; width: 100%;" src="https://zoom.us/wc/join/825227050" frameborder="0"></iframe>
	</div>

that worked!!

thanks very much for the prompt and effective help :slight_smile:

1 Like

Happy to hear it worked!

You are welcome! :slight_smile:

Thanks,
Tommy

1 Like

I am trying the following code but I am getting invalid meeting ID Invalid meeting ID. (3,001). Is it possible to embed this without using a meeting ID? I have tried using https://zoom.us/join/ in the Iframe src but that causes a redirect. Ideally, I want to IFrame the content on this page https://zoom.us/join on my website. Is that possible?

Hey @MCosta1108, thanks for using Zoom!

What meeting ID is giving you that error?

For the iFrame redirect issue, try adding this code to your iFrame,

sandbox="allow-forms allow-scripts"

Example,

<iframe src="https://zoom.us/join" sandbox="allow-forms allow-scripts"></iframe>

Thanks,
Tommy

1 Like

Thank you that is what I needed.

1 Like

You are welcome! Happy to help! :slight_smile:

Hi @michael_p.zoom,

Thanks for an iframe code.
I embedded iframe with my meeting ID to a web server. Login section is shown on a website. When the user enters a name and clicks on the “Join” button nothing happens. Is it a solution to fix an issue?
Please find a screenshot:

Hey @Mindaugas,

You could solve this by bypassing the meeting id and name input by using the following url as your iFrame src, which takes you right into the meeting,

https://zoom.us/wc/{{ meetindID }}/join?prefer=1&un={{ base64Encoded Name }}

Example

<iframe src="https://zoom.us/wc/{{ meetindID }}/join?prefer=1&un=TWluZGF1Z2Fz" sandbox="allow-forms allow-scripts" allow="microphone; camera; fullscreen"></iframe>

Let me know if this helps!

Thanks,
Tommy

1 Like

Hi @tommy,

Thank you for your reply.
I have used following iframe for testing:

<iframe src="https://zoom.us/wc/436717859/join?prefer=1&un=TWluZGF1Z2Fz" sandbox="allow-forms allow-scripts" allow="microphone; camera"></iframe>

Solution doesn’t work properly. It shows ‘Joining Meeting…’, but never joins it. Is it a solution to fix an issue?

Please find a screenshot:

@tommy,

I have tried to enter additional property sandbox="allow-same-origin" Then another “Unknown Error” is produced. Highly appreciate any help to fix it.
Full iframe looks like that:

<iframe src="https://zoom.us/wc/436717859/join?prefer=1&un=TWluZGF1Z2Fz" sandbox="allow-forms allow-scripts allow-same-origin" allow="microphone; camera"></iframe>

Please find a screenshot:

Hey @Mindaugas,

Thanks for the details!

Can you check your chrome settings and make sure you are allowing cookies?

Chrome Settings > Advanced Settings > Under Privacy and Security click Site Settings > Cookies > Make sure “Allow sites to save and read cookie data (recommended)” is checked and “Block third-party cookies” is unchecked.

I found this by googling the error.

Thanks,
Tommy

Apparently this iframe example works for me, however it only does video-wise but I can’t seem to hear anything from the meeting and when I click join audio I get this error in the console. “avsocket audio did not initial successful”, everything does work though if I’m using it on my localhost version of the app but on my production site (domain) audio doesn’t seem to work.

iframe:

<iframe style="border:none; height: 600px; width: 100%;" src="https://zoom.us/wc/{meeting-id}/join?prefer=1&un=TWluZGF1Z2Fz" sandbox="allow-forms allow-scripts allow-same-origin" allow="microphone; camera"></iframe>

here’s a screenshot cause I can’t upload pictures in my reply for some reasons.

Hey @omar.saleh, thanks for reaching out and using Zoom!

I was able to reproduce your issue. Basically the browser is blocking turning on the audio programmatically via the prefer=1 query param.

The AudioContext was not allowed to start. It must be resumed (or created) after a user gesture on the page. https://goo.gl/7K7WLu

To fix this, use prefer=0 and have the user click the Join with Computer Audio button, and allow site to access microphone.

Then you should be able to hear the participant from the iFrame.

<iframe style="border:none; height: 600px; width: 100%;" src="https://zoom.us/wc/{meeting-id}/join?prefer=0&un=TWluZGF1Z2Fz" sandbox="allow-forms allow-scripts allow-same-origin" allow="microphone; camera"></iframe>

Let me know if this works!

Thanks,
Tommy

Thanks for that. It works for me, but with one problem.

Although I pass the encoded name, I still being asked to enter my name and only then click Join. Can I skip that step and join automatically?

Hey @shimi, happy to help!

This is happening because your meeting requires a password.

If you want to use a password and join the meeting with the webclient url, add this query param: &pwd=passwordhere

For example,
https://zoom.us/wc/{meeting-id}/join?prefer=0&un=TWluZGF1Z2Fz&pwd={password}

Thanks,
Tommy