Failed to execute 'shaderSource' on 'WebGLRenderingContext': parameter 1 is not of type 'WebGLShader'

One of our user faced an issue with the receive video during a meeting after another participant activate screen sharing.

Bug effect: On the non host participant, the video received from the host participant is not displayed / visible anymore.

From our investigation we could notice the following javascript error on the participant having the bug.

Failed to execute 'shaderSource' on 'WebGLRenderingContext': parameter 1 is not of type 'WebGLShader'

Report provided by the host of the meeting
After activating screen sharing, the non host participant (only other participant in the meeting) could no longer see the video even after I (the host of the meeting) switched it back on, and then after I tried to switch it off then on again several times. When that didn’t work we both left the meeting and logged back in. After logging back in the issue was resolved (even after screen sharing)

Here is the error, happened multiple times.

It seems to be a rendering issue.

Other details
When correlating the javascript errors from the non host participant with the host participant actions, we can see that they are triggered when the host is activating/deactivating his video and/or screen sharing (if you pay attention to the timing on both sides)

Which version?

To Reproduce(If applicable)
Cannot reproduce it.

Client environment

  • Device: Laptop
  • OS: Window 10
  • Browser: Chrome 86.0.4240.75

I also got the same error today for the first time on 1.8.1.

TypeError: Failed to execute ‘shaderSource’ on ‘WebGLRenderingContext’: parameter 1 is not of type ‘WebGLShader’.

userAgent: “Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/86.0.4240.111 Safari/537.36 Edg/86.0.622.51”,

Hey @rossy, @nvivot,

Thanks for reporting this, we will take a look and get back to you with what we find. :slight_smile: (CS-2470)


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.