Generating signatures server side for the web sdk with node.js

Sure, sorry.

It works now and then but it’s not stable. Sometimes I’m getting: “The signature has expired” as error message. What does that mean?

For what it worth, I suspected it has to do with the start_time of the meeting, and tried to join meetings both in the past and in the future, however I couldn’t find a consistent behaviour.
I could really appreciate if you can look into this as I can’t push it to production yet as it is @bdeanindy

Oh my! I’m sorry, I didn’t receive a notification about you responding a couple of weeks ago on this.
My apologies for just seeing your last message.

Could you provide me with the full request/response (complete with headers) where you are seeing both:

  • Failure
  • Success

Perhaps I can identify what the issue is from that information.

Hi @bdeanindy

Not so clear what you’re asking. Which request and responses? I’m working against the ZoomMtg SDK. I’m calling ZoomMtg.join. How do I get this call request/response? looked a little in the developer tools but couldnt find it…

Hey @shahar my apologies, please disregard. I commonly help debug our REST API with developers, and for I forgot this is for our JS Web SDK, please forgive me for the confusion. :smiley:

@Carson_Chen or @Michael_Purnell
Do you know what conditions while executing ZoomMtg.join will generate the The signature has expired error message?

Hi @shahar,

Usually when the signature is expired either your host is set to 0 or your trail license has expired.

What plan do you currently have? Are you on the Pro or using a trial license?

Thanks

@Michael_Purnell I’m using a free account for dev and a paid account for prod, and I always use role=0. This happens though both on dev and prod.

Hi @shahar,

We do have a code sample for generating signature via NodeJS here - https://marketplace.zoom.us/docs/sdk/Web-Client-SDK/tutorial/generate-signature.

If that doesn’t work, please email us your keys at developer@zoom.us so that we can take a closer look of why your receiving the error.

Thanks

I have had the same issue and I looked in the developer tools but couldn’t find it too! help wanted on Zoom

Hi Michael Purnell,

I am also getting the below error :
{method: “join”, status: false, errorCode: 1, errorMessage: “The signature has expired.”, result: null}

I am using Jquery also passing the correct signature still it’s give me above error. @one user system it is working fine however it is not working for rest of user system. We have checked ALL required configuration like Java version, source files, Jquery version, OS, browser version etc and it is same.
We have also putted the 5 sec delay using setTimeOut() function but no luck.

Can you please help me - What needs to be done ?

Thanks,
Manoj Sarode.

@manoj.sarode,

We have responded to this issue here:

Please let us know if you have additional questions