Getting Invalid "Access Token!" on fresh created app

Description
Today i started to get this Invalid Token error when try to create a meeting.

Error
{
“reason”: “Invalid Token!”,
“error”: “invalid_request”
}

Which App Type (OAuth / Chatbot / JWT / Webhook)?
OAuth

Which Endpoint/s?
oauth/token?refresh_token

How To Reproduce (If applicable)
Steps to reproduce the behavior:

curl -X POST -H "Content-Type:application/x-www-form-urlencoded" \ --user {client-id}:{client-secret} \ --data 'grant\_type=refresh\_token&refresh\_token={refresh-token}' \ https://zoom.us/oauth/token

  1. See error

Screenshots (If applicable)

The local account is pairing without issues. The problem happens only when i try to authenticate by token. App name is Test2 if this matters.

Hi, @mladen,
Thank you for posting in the Developer Forum. Are you able to confirm you are always using the newest refresh_token that is returned with every [refresh request] ?

I’ve linked a similar Developer Forum post that may be a useful point of reference :

Please let me know if this helps.

Kindly,
Donte

Hi @donte.S Thanks for the quick response. No i don’t use two accounts, also i don’t use the scenarios from the tread you are referring. My postman gives me the error on newly created refresh token (as you can see from the screenshots).

I tried different ways to pass app key and secret with same result.

Please advice.

Hey @mladen,

Please make sure that you are using a Content-Type header of application/json. Further, instead of using the --data argument to send POST body data to the endpoint, you’ll want to set the values as query parameters instead.

Here’s an example of how the cURL command would look:

curl -X POST -H "Content-Type: application/json"  \
--user {client-id}:{client-secret} \ 
https://zoom.us/oauth/token?grant_type=refresh_token&refresh_token={refresh-token}

I hope that helps!

Thanks,
Max

It seems to work now. I didn’t change anything in the code as in similar tread before.

1 Like

Hey @mladen,

Great! I’m glad to hear that it’s working now. I’ll go ahead and close this topic now but feel free to open a new topic if you encounter any further issues or questions.

Thanks,
Max