Getting mismatch uri while getting access_token

I am creating zoom oauth application. created application. First I tried to run redirect url on localhost:3000/auth-code server and it worked perfectly.
Then I am planning to deploy this code on a server. and hence updated the redirect uri.
New redirect uri is .

Application is working good. getting code after authorisation worked.
BuT, when trying that code to get user access token, it always failing.
and saying
“Invalid request : Redirect URI mismatch.”

Browser Console Error
“Invalid request : Redirect URI mismatch.”

And If I am using localhost:3000/auth-code then it’s working very good.

Our server works on VPN just for information.


Hi @raju.panwar ,

I just want to confirm that you created an OAuth application and not an SDK application?

If it’s an OAuth application, did you change the redirect url to the new one under app credentials?


This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.