Getting No Meetings Back for other Users

I’m just a simple man trying to help his company out by getting some playurls from the API.

I am hitting /users to get a list of users. That comes back fine
Then I’ve pass the Id from that call into this call

That worked great for me. Super exciting.

Then I tried it for another user I knew had recordings and got nothing.
Response: 200 OK {}

I had another user share a video internally and it got the same response when using his ID (I also tried email for both users).

I see that I need recording:read:admin permissions. However, based on other posts on the forum, I have those since A) I am getting a 200 back and B) I can get my own recordings back by passing my ID instead of me.
To be clear, I have seen this page:

What I mean is: I don’t know how to determine which permissions I have.

I think this has got to be a bug because it’s returning 200 with no body.

I’m not really sure where to go from here.

1 Like

Hey @smiller, thanks for posting and using Zoom!

Are you using a JWT or OAuth app type?

If OAuth, can you confirm it is an Account-level OAuth app and you have added the recording:read:admin scope?


I am using JWT.

Also, I am not creating my own token. I am using the one from the developer portal that is created for me.

Thanks @smiller, I was able to reproduce your issue.

I fixed it by passing in the required to and from query params.

For example:{userId}/recordings?to=2019-09-11&from=2018-06-05

Try adding the to and from query params and let me know if it works.


I will not be able to get to this until tomorrow, but I will let you know. Thanks for the response.

1 Like

No rush! Happy to help, and looking forward to your response! :slight_smile:

Thanks for the idea. I am able to get meetings back from the call now.

What date should I put for the to date? I noticed if include the 12th (today in UTC), it came back with an empty object, just like before. What timezone should I use to calculate “Today”? Will it vary user to user?

On further inspection, I am still not getting all of the recordings. I will look into this tomorrow as there could be a simple explanation.

Hey @smiller,

Good to hear you are getting data now!

The date has to be in the YYYY-MM-DD format, and the Zoom server treats it as UTC.

How many are you missing? Note: this is only for cloud recordings.


Alright, I was able to resolve the rest of my issues.

I’m not sure what date range you are allowed, but it is less than the 6 months specified in the documentation. If you specify more, it will give you some number of values that I’m not sure how it determines. Maybe it goes back 30 days?

Anyway, thanks for the help and I hope you’re able to fix the issue with large date ranges less than 6 months.

Hey @smiller,

Happy to hear you were able to resolve your issues :slight_smile:

Have you tried changing the page_size query param, or using the pagination?


I tried both with and without pagination and got the same results. For the user I remember specifically, I got 5 results when I should have gotten 12. For now, I can just make many calls to the api with smaller ranges.

Okay, let us know if you run into any other issues!