I have created the zoom app, it's still in the testing phase. When I try to open the app in the zoom client. It display the blank page

I believe that you are using the sandbox browser, can you please confirm which type of browser you are using to display the app and the browser version?

1 Like

What is displayed in the dev console?

The embedded browser is what comes natively with the OS.

How to open a dev console in the zoom client?

You can follow these steps: Zoom Developer Docs

Then, right click the web view to inspect

Thank you so much. I have resolved this issue.

Mine also returns blank. The console says the following:
“403 Forbidden, domain or scheme is not allowed: about: blank”

I’m using React and TypeScript.

Index.tsx is pretty much the same as displayed here: zoomapps-advancedsample-react/index.js at main · zoom/zoomapps-advancedsample-react · GitHub

App.tsx uses “BrowserRouter, Routes, Route” from “react-router-dom” to route to different path.

The page that I’m trying to render but returns mentioned error is just the default “/” and tries to render a .tsx view.

UPDATE: I solved the problem. I had to add the URL to “App credentials” → “Domain Allow List”

UPDATE 2: It seems to only work on Windows when using Edge. I tried on a Mac which uses safari as its native browser but then I recieve the following error:

Missing OWASP Secure Headers: ["Strict-Transport-Security","X-Content-Type-Options","Content-Security-Policy","Referrer-Policy"] for URL ...ngrok.io

Same goes for me, my app works perfectly on windows but on mac I am getting the OWASP error.

I keep getting 403 Forbidden, domain or scheme is not allowed. I configured headers (although maybe incorrectly) and added domain/urls. The home page seem to load with 200, but nothing is rendered…

My headers were incorrect. An example of valid headers can be found here zoomapps-advancedsample-react/server.js at main · zoom/zoomapps-advancedsample-react · GitHub

2 Likes

Thanks for sharing what worked for you.

@15hannils @tech10 Does that fix the issues you were seeing?

Yes, I have successfully fixed this issue.

How did you fix your issue? I am having the same problem where my app works on Windows, but I get the missing OWASP Secure Headers error on Mac.

Missing OWASP Secure Headers: ["Strict-Transport-Security","X-Content-Type-Options","Content-Security-Policy","Referrer-Policy"] for URL ...ngrok.io

It sounds like this may be an issue with Ngrok that has since been resolved. Try upgrading to the latest version to see if that solves your issues.

1 Like

Same issue was having for me: https://marketplace.zoom.us/docs/zoom-apps/referenceapp/#enabling–developer-tools but it’s resolved by following these steps.