Incorrect API scope required for "GET /metrics/webinars/{webinarId}/participants"

Testing further…suddenly working.


When requesting participants from /metrics/webinars/{webinar_id}/participants, I get the following error: {'code': 4700, 'message': 'Invalid access token, does not contain scopes: [dashboard:read:admin, dashboard_webinars:read:admin].'}. According to the documentation, only dashboard_webinars:read:admin is required. This scope is available to the provided access_token:

‘token_type’: ‘bearer’, ‘expires_in’: 3599, ‘scope’: ‘webinar:write:admin dashboard_home:read:admin webinar_token:read:admin:live_streaming report:read:admin dashboard_webinars:read:admin meeting_token:read:admin:live_streaming dashboard_meetings:read:admin meeting:write:admin’

Screen Shot 2023-02-28 at 5.24.07 PM

It looks like the error message you received is indicating that your access token does not have the required scopes to access the participants endpoint for webinars.

Based on the scope listed in the access token you provided, it appears that you have the dashboard_webinars:read:admin scope which should allow you to access the /metrics/webinars/{webinar_id}/participants endpoint.

However, if you are still receiving an error, it’s possible that there may be an issue with the specific access token you are using. You may want to try regenerating a new access token with the required scopes and see if that resolves the issue.

If the issue persists, you can try reaching out to Zoom support for further assistance in troubleshooting the issue.

1 Like

Thanks for chiming in @anawilliam850
you are spot on there!
And @whall have you been able to troubleshoot this issue?


Yes, the error message does indicate I don’t have the required scope.

As you noted, the token did have the required scope listed in the documentation. I received an error message that should not exist, per the documentation.

The issue did resolve itself after I contacted support chat and was told to try the forums as I would get better answers here.

I have been unable to to replicate the same error message since contacting support, so your suggestion of “wait and try again” appears to have worked. Thanks!

Hi @whall

I am happy to hear that is working again.
I have not seen an issue like this one before, so if this happens again, please reach out to me and I will help you looking into it