Issues with Exporting or Packaging C# Wrapper SDK

Description
I have a client application in WPF working great on my local machine. The issue is that whenever I package it up either copying the executable and all libraries together, or combining them into an MSI installer, on the newly installed machine I always get a message:

Unhandled Exception: System.IO.FileNotFoundException: Could not load file or assembly 'zoom_sdk_dotnet_wrap.dll' or one of its dependencies. The specified module could not be found.

Even though the zoom_sdk_dotnet_wrap.dll is in the same directory as the executable.
The target machines all allow 32-bit applications to run fine without a problem. Even in cases where I am copying the Release directory as is that is running fine on my machine to another computer, I still get that same error.

Does it need to be referenced or activated on the new machine in some way that I’m not aware of to be recognized?

Which Windows Client SDK version?
5.5.12509.0330
Assembly zoom_sdk_dotnet_wrap, Version=1.0.7575.37543

Device (please complete the following information):
Windows 10

Hey @tyler,

Thanks for using the dev forum!

This is likely due to a some file path setting that is valid in your local environment but not otherwise.

Thanks!
Michael

@Michael_Condon Files are all in the same directory as the EXE, and they’re not explicitly referenced in a path anywhere in the code, so I don’t think it’s that. This was my first thought along with making sure the EXE was in x86 so it wasn’t missing the DLLs that are also x86.

Are the SDK DLLs somehow linked to the machine they are downloaded into or run the first ime in some explicit way?

Hey @tyler,

I dont believe so. The demo application will run immediately after download, so I do not believe it is possible that they are hardwired to a specific machine.

Michael

OK. It’s very strange cause I can copy the directory on my own machine into any directory and it works fine, but as soon as I copy that exact directory on to a different machine it doesn’t work. I will update here if I figure out what the issue is

As an extra sanity check, I copied the entire directory into another machine and I still get the error

Hey @tyler,

You could try using a dependency walker to identify what the issue is: GitHub - lucasg/Dependencies: A rewrite of the old legacy software "depends.exe" in C# for Windows devs to troubleshoot dll load dependencies issues.

Michael

@Michael_Condon I’ve tried that already, didn’t derive anything useful.