java.lang.UnsatisfiedLinkError has been throwed When initialize ZoomSDK

Hi Arun,

Thanks for the reply. I will consult the engineers and get back to you.


Hi Arun

If you use customize UI .
You can refer to example2 to implement the task.

step 1: add a config.xml on values
step 2: set the meeting activity class name with key zm_config_conf_activity: us.zoom.sdkexample2.MyMeetingActivity
step 3: override onBackPressed method in MyMeetingActivity

1 Like

Hi Fred,
thanks for reply. I have not customised any UI part but I’ll try with your solution and get back to you. FYI I am using webinar if there anything I need to change for that

Hi Arun,

Just tested the method Fred was mentioning with our example2 app and joining a webinar. And it is working. Here is the method that I used in MyMeetingActivity:

	public void onBackPressed() {
		InMeetingService im = ZoomSDK.getInstance().getInMeetingService();
		if (im != null) {

Hope this helps. Thanks!

Thanks Carson,

I am not using MyMeetingActivity , I am using and back press handling not working.

Is it compulsory to use MyMeetingActivity for webinar or it is OK to use If it is OK help me with back press handling. For me code control not coming to back press. if is there any kind of config I need to change do let me know

Hi Arun,

Thanks for the reply. Neither MyMeetingActivity nor MainActivity are SDK classes. As long as you extends MeetingActivity, and follow Fred’s 3-steps:

  1. Add a config.xml file in values
  2. Set the meeting activity class name with key “zm_config_conf_activity”:us.zoom.sdkexample2.MainActivity
  3. Override the onBackPressed method

If you are still having issues, could you share the following information:

  1. The settings in config.xml
  2. The Activity class that you extends the MeetingActivity and overrides the onBackButtonPressed
  3. The onBackButtonPressed method


Hi, I was looking latest SDK, there are two projects, which one I should follow : example2 or


Right now I am working with exmaple2 and in that there is Activity class “MainActivity”



Thanks for the reply. The example2 and sample are demo apps that are demonstrating different scenarios, they are the app that shows how to integrate Zoom SDK into an application and how to use SDK interfaces.

The MainActivity is a class in the demo application, not in the SDK.


Thanks Carson for reply,

You are right those are sample app which used SDK to demonstrate the working on SDK but in Example2 App OnbackPress is not handled and when try to implement method on backPress flow control didn’t come to on backPress. Actually on backpress I want to leave running meeting/webinar.
I have imported the code from git and added SDK key and secret Key. other than this I didn’t change anything

I am trying new SDK so is it necessary to move to androidx for the latest version.I have just replaced aar, gradle and iml files. Above attached image is the problem I am facing.

Stack Trace :
Error:Supertypes of the following classes cannot be resolved. Please make sure you have the required dependencies in the classpath:
class, unresolved supertypes:

Hi Arun,

Thanks for the reply. Yes, upgrading to AndroidX project is a requirement, please see:

Once you upgrade your project to AndroidX, then this error will go away.


Thanks Carson, updates SDK is working fine but still facing issue onBackPress Handling.
When I put config file in values a different UI is opened when start a meeting and backPress is handled , when I don’t put config file UI is expected but onBack is not working.

Can you tell me what is the use of config.xml

Hi Arun,

Glad to hear that the back press is handled. The config.xml is used for configuring the meeting Activity.


Hi Carson,

One more question when I put config a different UI is opened! Screenshot_20190801-193822|250x500 . How to avoid this screen .


Hi Arun,

Are you using the my_meeting_layout.xml in the example2? That UI is a demo layout and you can change it.


Thanks Carson , backpress is handled , new SDK is working but using this SDK app size is increased by 10-12 mb . Is there any way to avoid that .

ndk {
abiFilters “armeabi-v7a”, “arm64-v8a”

Above is ABI filters I am using .


Hi Arun,

Thanks for the reply. You may refer to the answer here to reduce your size: App size estimate


1 Like

Thanks Carson, its working now

I am using WebSDK version 1.5.0 to join a meeting and using the sample code provided with it.

When I try to join a meeting I get “Not support registration webinar” error,
But the webinar I am trying to connect is not registration based

Carson can you help me with this or redirect to correct thread


Hey @goyal.arun16,

Are you setting the userEmail?

“In your index.js file and within the join method you will need to set make sure the userEmail property is set.”

Also confirming, you have the role set to 0 in your meetConfig object?