Meeting created on wrong date and time

We’re passing the following body when creating a new scheduled meeting for “2020-11-25T19:00:00” Berlin timezone.

{“agenda”:"",“recurrence”:{“type”:2,“repeat_interval”:2,“end_date_time”:“2021-02-17T18:00:00.000Z”},“created_at”:“2020-11-16T10:47:34.998Z”,“start_time”:“2020-11-25T19:00:00”,“timezone”:“Europe/Berlin”,“duration”:90,“topic”:“Test-Zoom*”,“type”:8,“settings”:{“join_before_host”:true,“audio”:“both”,“mute_upon_entry”:false,“participant_video”:true,“host_video”:true,“use_pmi”:false}}

However int response we get a completely different date and time for the start date! What’s going on and how do we fix this?

{“uuid”:"-----",“id”:-----,“host_id”:"-----",“host_email”:"------",“topic”:“Test-Zoom*”,“type”:8,“status”:“waiting”,“timezone”:“Europe/Berlin”,“created_at”:“2020-11-16T10:47:35Z”,“start_url”:"-----",“join_url”:"------",“occurrences”:[{“occurrence_id”:"----",“start_time”:“2020-12-06T18:00:00Z”,“duration”:90,“status”:“available”},{“occurrence_id”:"----",“start_time”:“2020-12-20T18:00:00Z”,“duration”:90,“status”:“available”}],“settings”:{“host_video”:true,“participant_video”:true,“cn_meeting”:false,“in_meeting”:false,“join_before_host”:true,“mute_upon_entry”:false,“watermark”:false,“use_pmi”:false,“approval_type”:2,“audio”:“both”,“auto_recording”:“none”,“enforce_login”:false,“enforce_login_domains”:"",“alternative_hosts”:"",“close_registration”:false,“show_share_button”:false,“allow_multiple_devices”:false,“registrants_confirmation_email”:true,“waiting_room”:false,“request_permission_to_unmute_participants”:false,“recurrence”:{“type”:2,“repeat_interval”:2,“weekly_days”:“1”,“end_date_time”:“2021-01-02T09:47:00Z”}}

I can see that this only happens when you set type = 8 but that’s what is needed, otherwise Zoom does not create a recurring meeting and does not honor the recurrence data passed. Is this a bug?

How do we get around this?

Actually no matter what we do, Zoom picks the wrong date. I’ve tried passing the date and time in UTC format and the time gets picked correctly but with the wrong date (4 days of difference)

Hi @fahad.beehive,

You will need to pass a valid weekly_days field within the recurrence object, which appears to be the issue. I also noticed you’re passing a “created_at” field in your request, which is not needed.

Please try making this 1 addition to your request body to ensure the request is being processed correctly:

{
 "agenda":"",
 "recurrence":{
   "type":2,
   "repeat_interval":2,
   "weekly_days":4,
   "end_date_time":"2021-02-17T18:00:00.000Z"
   },
 "start_time":"2020-11-25T19:00:00",
 "timezone":"Europe/Berlin",
 "duration":90,
 "topic":"Test-Zoom*",
 "type":8,
 "settings":{
 "join_before_host":true,
 "audio":"both",
 "mute_upon_entry":false,
 "participant_video":true,
 "host_video":true,
 "use_pmi":false
   }
} 

Let me know if this helps!

Best,
Will

Thank you - I’ll give that a try, however I don’t see that this has been properly documented, also should the call not fail instead of creating a meeting at a different date altogether? This is confusing and I still consider this to be a bug at Zoom’s end.

Can you advise what I need to do if this was a monthly / daily recurring, timed meeting?

Hi @fahad.beehive,

Thanks for raising this. We will work on updating our documentation to reflect that this is a required field when creating a recurring meeting via API. (cc @shrijana.g)

For monthly/daily recurring meetings, you can adjust the type field accordingly, and then pass one of these fields in place of weekly_days:

Thanks,
Will

1 Like