Meeting setting missing from GET but

Description
I am not seeing the new “meeting_authentication” key returned from the get settings api call for both an account and a group. I am seeing the key in the GET settings_lock endpoint. And a recent update says is should be available from the update setting response. I would expect to see it in the GET settings as well.

JSON Response missing data

“meeting_authentication”: false

Which App Type (OAuth / Chatbot / JWT / Webhook)?
The issue is seen using Oath and a zoom app.

Which Endpoint/s?
From the following api calls.
https://api.zoom.us/v2/groups/bjjqsX-BRPKmLRVRIqSmyw/settings
https://api.zoom.us/v2/accounts/me/settings

Screenshots (If applicable)

{
  "schedule_meeting": {
    "host_video": false,
    "participant_video": false,
    "audio_type": "both",
    "join_before_host": false,
    "personal_meeting": true,
    "use_pmi_for_schedule_meetings": false,
    "use_pmi_for_instant_meetings": false,
    "force_pmi_jbh_password": true,
    "require_password_for_scheduling_new_meetings": true,
    "require_password_for_scheduled_meetings": true,
    "require_password_for_instant_meetings": false,
    "require_password_for_pmi_meetings": "jbh_only",
    "pstn_password_protected": false,
    "mute_upon_entry": false,
    "upcoming_meeting_reminder": false,
    "embed_password_in_join_link": true
  },
  "in_meeting": {
    "e2e_encryption": true,
    "chat": true,
    "private_chat": true,
    "auto_saving_chat": true,
    "entry_exit_chime": "none",
    "file_transfer": true,
    "feedback": true,
    "post_meeting_feedback": false,
    "co_host": false,
    "polling": false,
    "attendee_on_hold": false,
    "show_meeting_control_toolbar": false,
    "allow_show_zoom_windows": false,
    "annotation": false,
    "whiteboard": false,
    "remote_control": false,
    "non_verbal_feedback": false,
    "breakout_room": false,
    "remote_support": false,
    "closed_caption": false,
    "far_end_camera_control": false,
    "group_hd": false,
    "virtual_background": true,
    "alert_guest_join": false,
    "auto_answer": false,
    "sending_default_email_invites": false,
    "use_html_format_email": false,
    "custom_data_center_regions": false,
    "stereo_audio": false,
    "original_audio": false,
    "show_device_list": false,
    "only_host_view_device_list": false,
    "screen_sharing": false,
    "waiting_room": true,
    "participants_to_place_in_waiting_room": 0,
    "show_browser_join_link": false
  },
  "email_notification": {
    "cloud_recording_available_reminder": true,
    "jbh_reminder": true,
    "cancel_meeting_reminder": true,
    "alternative_host_reminder": true,
    "schedule_for_host_reminder": true
  },
  "recording": {
    "local_recording": true,
    "cloud_recording": true,
    "record_speaker_view": true,
    "record_gallery_view": false,
    "record_audio_file": true,
    "save_chat_text": true,
    "show_timestamp": false,
    "auto_recording": "none",
    "cloud_recording_download": true,
    "cloud_recording_download_host": false,
    "account_user_access_recording": true,
    "host_delete_cloud_recording": true
  },
  "telephony": {
    "third_party_audio": false,
    "audio_conference_info": ""
  }
}

On second thought, perhaps I don’t understand the difference between

“enforce_login”: true,

and

“meeting_authentication”: true

Hey @derek1,

This mirrors the “Only authenticated users can join meetings” setting.

This mirrors the authentication profiles setting:

Let me know if you have additional questions! :slight_smile:

Thanks,
Tommy

1 Like