More than one file was found with OS independent path 'lib/arm64-v8a/'

We currently use zoom version v5.0.24433.0616 in our Android mobile app. We also use amazon chime in our app(currently version 0.7.3 of the android sdk) . For now things are ok, both amazon chime sdk and zoom sdk work ok on our current versions. However, if I try to update to the latest zoom sdk, which is v5.2.41727.0928, it gives me the compilation error "More than one file was found with OS independent path ‘lib/arm64-v8a/’ ". I tried everything I found on the internet to make it work, with no success. The only way to make the app compile is to add

packagingOptions {
exclude ‘lib/x86/’
exclude ‘lib/arm64-v8a/’
exclude ‘lib/x86_64/’
exclude ‘lib/armeabi-v7a/’
in the android tag in build.gradle of the app. But that of course will crash the app when accessing either zoom or chime sdk features.

Which version?

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Use amazon chime sdk 0.7.3
  2. Use zooom sdk v5.2.41727.0928
  3. Compile the app

Additional context
Really doesn’t matter these but just to give an example
Android 9 or Android 10
compileSdkVersion 29
buildToolsVersion “29.0.3”
Android Studiu 4.1.1 (latest version)
ext.kotlin_version = ‘1.3.61’

My question is, what should we do in order to update the zoom library, and still be able to use chime as well? Thanks

Hi @daniel3, thanks for the post.

This is a known issue with the latest version of the Android SDK. Please see the linked post for information on how to resolve this.


We are using pjsua2 and we see same error

2 files found with path ‘lib/arm64-v8a/’ from inputs:
-/ xxxx/pjsua2/build/intermediates/library_jni/debug/jni/arm64-v8a/

  • /xxxxx/mobilertc/build/.transforms/445b8adf65ed1845334c5eaf41712982/transformed/jetified-mobilertc/jni/arm64-v8a/

Getting same issue though I use latest Android SDK (31) and used packagingOptions {pickFirst ‘**/*.so’}, JNI layer is throwing exception when we join a call, more logs can be found in Here