No signature of method

I have created a new flutter application and as per documentation also added mobilertc.aar file in my android module and configured. after that I have updated gradle with 8.0.1 finally when I am trying to run this project at that time I am getting below error also I have tried Native android SDK that also having same error.
No signature of method: org.gradle.api.tasks.bundling.Jar.destinationDir() is applicable for argument

If Anyone has an idea about this issue then please help me.
Thanks

Hi @pinal.dhaduk,

Thanks for showing interest in our new Flutter Video SDK.

That “No signature of method” seem to be an error coming from your gradle file. Since you have also update gradle to the latest version 8.0, can you kindly check the following:

  1. Check your flutter version and upgrade it to latest version using ‘flutter upgrade’ command,
  2. Run ‘flutter clean’
  3. Invalidate the cache. This is necessary because often the error can also be caused by Gradle cache. You can do so by going to 'File > Invalidate Caches/Restart" in your Android Studio.
  4. In your ‘android/build.gradle’, check for any incompatible plugins or dependencies.

Thank you.

@pinal.dhaduk I’ve just tried on my Mac (M1), and it seems to deploy to my android phone.

Here are my versions

flutter --version
Flutter 3.7.6 • channel stable • GitHub - flutter/flutter: Flutter makes it easy and fast to build beautiful apps for mobile and beyond
Framework • revision 12cb4eb7a0 (31 hours ago) • 2023-03-01 10:29:26 -0800
Engine • revision ada363ee93
Tools • Dart 2.19.3 • DevTools 2.20.1

image

For the downloaded flutter SDK, there is already mobilertc.aar included.

  • I did not add the mobilertc.aar from android SDK.
  • I have left the gradle version as is

Are you using Mac or Windows @pinal.dhaduk ?

1 Like