Not able to get whats wrong

Hi @navneet.techlene, thanks for the post.

Sorry to hear you are running into this error. Can you please try checking out this thread for a similar issue and letting me know if the solutions there are not working for you?

Thanks!

I have Already Gone through this 2-3 times

Hi @navneet.techlene,

Can you please let me know specifically which steps you have already taken so that I can better advise you on the next steps?

Thanks!

updated to android x
gradle:3.4.2

compileSdkVersion = 30
buildToolsVersion = "30.0.3"
minSdkVersion 21
targetSdkVersion 30

then started importing

commonlib
mobilertc

from project Structure
Modules option
add new module

then using
Dependencies option


added implementation of the both modules

then tried for run project and this is the result

it shows mobilertc:unspecfied

Hi @navneet.techlene,

It seems that there are still some other solutions from that other thread which you have not yet tried. Please see this reply for more information. Let me know if you are still unable to get this working after following the suggestions mentioned there.

Thanks!

D:…app\build\intermediates\incremental\mergeDebugResources\merged.dir\values\values.xml:18551: AAPT: error: duplicate value for resource ‘attr/foregroundColor’ with config ‘’.

mobilertc\build.transforms\c633a213e940dad0908ae23ef72e33e2\jetified-mobilertc\res\values\values.xml:5854:5-5858:25: AAPT: error: resource previously defined here.

Now these

…\mobilertc\build.transforms\c633a213e940dad0908ae23ef72e33e2\jetified-mobilert
c\res\values\values.xml:5854:5-5858:25: AAPT: error: duplicate value for resource ‘attr/foregroundColor’ with config ‘’.

 D:.........mobilertc\build\.transforms\c633a213e940dad0908ae23ef72e33e2\jetified-mobilert

c\res\values\values.xml:5854:5-5858:25: AAPT: error: resource previously defined her

Hi @navneet.techlene,

What changes have you made in your project since you began seeing this new error?

Thanks!

based on this I set formatted=“false” after coping into my project string and i am available all night and next too. Like resolve it
asap

because its mobilertc files i am not able to edit it

Hi @navneet.techlene,

Can you please let me know which changes you have made in your project so that I can assist? This is not the same error that you were previously reporting, so something has changed.

Thanks!

Hey, I am having the same problem. have you got any solution yet?

1 Like

I already added these error too and its in mobilertc value folder String thats why i was not able to edit so I copied that data in my string xml and added formatted = false


after that some error stopped popping up now i am dealing with these errors

Kindly let me know if you are able to resolve it.

Hi @logan033,

Can you please let me know which suggestions from this thread you have tried already?

Thanks!

Hi @navneet.techlene,

Are you saying you copied the content over from the SDK into your own file so you could add that attribute? That is going to guarantee that you can’t build the app, because you now have a ton of resources with conflicting names. Can you please try the suggestions I mentioned in this reply?

Thanks!

Okay, I’ll do that but can you tell me how to edit mobilertc files because what solution you have given me to that how can edit that you have told me and this foregroundcolor error I already have it in my first question can you read it?

Hi @navneet.techlene,

You cannot modify the SDK’s files. Please let me know if you’ve had any luck with the suggestions from the other thread.

Thanks!

so how can i remove these error now . no luck

I did everything I could but the library is just not compatible. I tried an older version. And it worked for me for API level 29.