Parameter 'args' implicitly has an 'any[]' type version @zoomus/websdk@1.9.0

Thanks @Dhruv_Chopra ,

We will continue investigating this issue.

Stay tuned.


Hey @Dhruv_Chopra ,

We are confident the issue was fixed in 1.9.1. Can you please try deleting your node_modules and NPM installing again to confirm you have the latest Web SDK version? Make sure you also have the latest version in your production env where you are having the issue.


Hey @tommy, we did the same things multiple times but showing the same error.

websdk/index.d.ts at 9b8fde8b8909d62a92b77d20d647ec6cbdff245b · zoom/websdk · GitHub

Hey @Dhruv_Chopra ,

This line shows that it is updated. :slight_smile:


Still getting the same error, I deleted the node modules and installed it again, still shows the same issue, the line was updated but the return type was not specified right

Hey @vasanth ,

Thanks for letting us know. We are taking another look at this.

We will make this change in 1.9.5. For now, a local change to type.d.ts should suffice. If you are concerned with automated pipelines, try updating your tsconfig file to allow implicit any for now.


1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.