Web SDK Version 1.7.6 is now live!

Hello Zoom Developers,

To further align with our Security initiative, we’ve released a new version of the Web SDK version 1.7.6. This version comes with an addition of the Security icon & bug fixes for leaving webinars.

For full details about 1.7.6, please visit the latest Web SDK change log page .

To get started, you can find the latest Web SDK version in the following locations:

  1. NPM: https://www.npmjs.com/package/@zoomus/websdk
  2. Sample Web App repo: https://github.com/zoom/sample-app-web
  3. Angular Sample App repo: https://github.com/zoom/websdk-sample-angular

As Always
#codeHappy

@Michael_Purnell we don’t see the git repo updated, any reason why that has lagged? https://github.com/zoom/websdk

Hello there, @Michael_Purnell.
Just cloned websdk-sample-angular and install dependecies. Seems to work (after applying API key, userName, etc.), it work perfectly indeed, but console complains a couple of times (tested in lastest Chrome and Edge).

Just FYI, did not find further implications
Best Regards

Hey @stan_b,

Apologies, we have now updated the Web SDK on GitHub:

Thanks,
Tommy

Hey @desarrollos.nit,

We are aware of the CSS warning, and will look into the invalid url issue.

Thanks,
Tommy

1 Like

Hey @tommy,

Same issue.

Uncaught (in promise) TypeError: Failed to construct 'URL': Invalid URL
at e.<anonymous> (js_media.min.js:1)
at D (js_media.min.js:1)
at Generator._invoke (js_media.min.js:1)
at Generator.e.<computed> [as next] (js_media.min.js:1)
at r (js_media.min.js:1)
at u (js_media.min.js:1)
at js_media.min.js:1
at new Promise (<anonymous>)
at new t (js_media.min.js:1)
at e.<anonymous> (js_media.min.js:1)

Also warning

DevTools failed to parse SourceMap: https://dmogdx0jrul3u.cloudfront.net/1.7.6/lib/webim.min.js.map
DevTools failed to parse SourceMap: https://source.zoom.us/1.7.6/css/bootstrap.css.map

@tommy we are also running into the same issue, please advise as we do not feel comfortable upgrading with multiple errors and warnings.

Hey @NKSM, @stan_b,

Please create new threads so we can better assist.

Thanks,
Tommy

Does this version have the Zoom thumbnail? We noticed that went missing when we switched to 1.7.4 and 1.7.5.

Hey @conradwalz,

What do you mean Zoom thumbnail?

Thanks,
Tommy

Inside of every zoom meeting the participant can see themselves in the bottom left corner of the screen. That feature is no longer available.

Hi @conradwalz,

Can you post a screenshot and any other errors that are showing within the console log please?

Thanks

IN the photo you will see me in the zoom meeting with another person. I see the other person but I have no way of seeing myself. We always had a little square box in the bottom right corner that we could see ourself and now we can’t. It’s a major issue.

We are facing the same issue conradwalz. Did zoom reply back with anything ? Also for us the leave meeting button is not working. If we click on it nothing happens.

The only thing they have said is “our developers are looking into this.” I’ve heard that for the past six weeks.

We are also facing the Invalid URL issue and also Leave Meeting not working.

We are also having this issue where we cannot see ourselves in meetings.
Posted here Picture in Picture Missing?

Hi
So I have tried to integrate the Zoom API into my angularjs application.
I am however

  • unable to join with computer audio
  • get the error “Cannot detect your camera, please check the device and connection and try again.” for my video. As seen in screenshot attached, video icon is disabled
  • Get the same error as others as regards the URL as in screenshot attached

Please help

@Michael_Purnell any update on the picture inside the picture? I haven’t heard anything back in over a week.
Thanks,
Conrad

Hey @conradwalz, @infinitizon, @sales1, @thendralvanan08, @rajat.odu,

Please post your issues in a new or related thread so Zoom and other developers can track and assist.

Thanks,
Tommy