React project: JsMediaSDK_Instance is not defined

Description
I’m trying to integrate the Web SDK with React, but It has not been successful.
When I try to join a meeting the error “Uncaught ReferenceError: JsMediaSDK_Instance is not defined” shows up. I saw that here in the forum there are a lot of issues related to it, none of the suggested solutions solved my problem. Is there a way to fix that? I would really appreciate some help on that.

I created a repo in GitHub to be easier to show my code. the main file is this one:
https://github.com/MuriloDutra/react-zoom/blob/master/src/App.js

Error
zoomus-websdk.umd.min.js:2 Uncaught ReferenceError: JsMediaSDK_Instance is not defined

Which Client Web SDK version?
@zoomus/websdk”: “^1.9.0”

Screenshots
ADD: Appearly I can access the meeting because I tested with one real user, through Zoom desktop app and then tried to access the meeting through my react application. The real user can see the react user in the meeting, but my application can’t show none of them.

Zoom Desktop app

My react application

Device:

  • Chrome: 88.0.4324.182 (Versão oficial) 64 bits
  • Brave: 1.20.108 Chromium: 88.0.4324.182 (Versão oficial) 64 bits

Hey @murilo.alves ,

Have you referenced the React Web SDK sample app? :slight_smile:

You can check it out here: GitHub - zoom/websdk-sample-react: Use the Zoom Web SDK in a React App

Thanks,
Tommy

1 Like

Thanks @tommy I’m going to use this example and see how it goes, thanks for the tip!

Thanks @tommy, the repo worked for me.

Hey @murilo.alves,

I’m glad to hear that @tommy resolved your issue! Please don’t hesitate to reach out if you encounter any further issues or questions.

Thanks,
Max

1 Like