Salesforce Integration Failing - how to update batch job running as inactive user

Description
The person who installed the Salesforce package left the company. We need to update the scheduled job that comes with the package. But I can’t select the class that’s scheduled in the scheduler, and I can change the settings because it’s a managed package.

How can I update this?

Hey @jdoan,

Thank you for reaching out to the Zoom Developer Forum. Just to clarify, are you looking to update to class or make customizations to it? If you want to bring the class to a newer version, you can update the entire package by following the steps here.

Let me know if that helps.

Thanks,
Max

Thanks Max!

I’m looking to update the running user on the scheduled job. When you install the managed package, a job is scheduled as the user that installs it. The class that’s being scheduled is called ‘MeetingMetricsBatch’. However, when I look at the scheduled jobs, I cannot modify the job associated with this class, and I cannot schedule a new job using this class either.

Because this user is inactive, the job fails to run. We upgraded the package in the lower environments, but the scheduled job does not get created in our lowers (not sure what that’s about).

Hey @jdoan,

Thank you for explaining. I don’t know if we have a method to change the owner of the Managed Package and therefore the user that runs the job without reinstalling the entire package. Have you had a chance to reach out to SFDC support to see if they would be able to change the owner of the package/job without reinstalling it?

Another option is to change the email, password and name of the managed package owner’s user so that it reflects it is supposed to be the integration user. You could then reactivate that user and the previous owner wouldn’t have access or continued notifications.

Thanks,
Max

Hi @MaxM
Is there any answer on the question of whether you have a method to change the owner? It seems that the scheduler class scheduleMeetingMetricsBatch isn’t global so it can’t be scheduled by another user directly. I get a “type is not visible” error when I try to do that. Is there a different way to call the same code that created the scheduled job during the install process?

At a minimum, you should update your installation steps to indicate this shortcoming. That is, it should be installed while logged in as the user that will run this job ongoing.

Hey @CJ_SL,

My understanding is that we don’t have a method to change the owner. You bring up a good point, we should update our documentation to indicate this is a limitation when installing. I’ll work with our team on this.

Thanks,
Max

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.