Sample app won't start (Error: ENOENT on "npm start")

Hi guys,
I downloaded the Fully customizable web .zip file and tried running the sample app from the “Sample&Libs” directory. But “npm start” shows the following error:

errorno: ENOENT
code: ENOENT

i can’t seem to find any specific reason for the exception. Any help would be greatly appreciated.

throw er; // Unhandled ‘error’ event

Error: spawn http://localhost:9999/index.html ENOENT
at Process.ChildProcess._handle.onexit (internal/child_process.js:267:19)
at onErrorNT (internal/child_process.js:469:16)
at processTicksAndRejections (internal/process/task_queues.js:84:21)
Emitted ‘error’ event on ChildProcess instance at:
at Process.ChildProcess._handle.onexit (internal/child_process.js:273:12)
at onErrorNT (internal/child_process.js:469:16)
at processTicksAndRejections (internal/process/task_queues.js:84:21) {
errno: ‘ENOENT’,
code: ‘ENOENT’,
syscall: ‘spawn http://localhost:9999/index.html’,

npm ERR! errno 1
npm ERR! instantsdk-demo@1.0.0 start: set NODE_ENV=development && set BABEL_ENV=development && webpack-dev-server --config --https false --open http://localhost:9999/index.html --watch

To Reproduce(If applicable)
Steps to reproduce the behavior:

  1. Download the zoom instant web sdk .zip file
  2. extract
  3. Go to “Sample&Libs” directory of the extracted dir
  4. Run “npm install”
  5. run “npm start”
    PS: i also tried copying “@zoomus” to node_modules directory after step 4. But the error still persists.
    i shared the screenshots of the error and my directory structure below.

Thanks and Regards,
Md. Mehedi


Hi Hasan,

I had the same problem, I solved with restarting the terminal . Make sure that

  1. you run npm install first
  2. copy @zoomus folder to node_modules (it must exists there)
  3. run npm run start

If the problem still exists, restart the terminal and try again

1 Like

If you working on Linux run this command rather than npm run start, it worked for me.

sudo webpack-dev-server --config --watch


Hey ,

Please let us know if you are still having issues!

Thank you for sharing possible solutions @blagojco , @aatir ! :slight_smile:


1 Like

No longer having the issue. Thanks a lot for the support.
But i am facing new issue. Can’t seem to remove a user even though i am a host.
client.removeUser(userId) throws fps error, type “OPERATION_TIMEOUT”.

Fully customizable sdk says host should be allowed to remove a user.
Any help will be greatly appreciated.
Thanks in advance,
Md. Mehedi
FYI: I’ll create a new topic on this issue. Feel free to share your advice there as well.

@tommy @blagojco @aatir

Thanks for creating a new topic , we will assist you there! :slight_smile: