SDKERR_UNINITIALIZE on meeting join; worked yesterday

In onLoginRet (which returns LOGINSTATUS::LOGIN_SUCCESS), I am doing:

ZOOMSDK::JoinParam meetingParameters;
meetingParameters.userType = SDKUserType::SDK_UT_NORMALUSER;
meetingParameters.param.normaluserJoin.meetingNumber = "123456";
meetingParameters.param.normaluserJoin.psw = "123456";

This is now returning SDKERR_UNINITIALIZE even though all previous stages have succeeded (login, init sdk etc.).

I am the using Zoom SDK from

Why would I get SDKERR_UNINITIALIZE ? This worked yesterday(without normaluserJoin.psw).

Is there a log file to troubleshoot this??

To Reproduce(If applicable)
All stages until onLoginRet as before.

Device (please complete the following information):

  • Device Spec: PC
  • OS: Windows
  • Version 10

One idea I do have is that I now include openssl statically in my binary.

Does Zoom SDK use OpenSSL? If so, what version does it use?

I’ve tried to use mbedTLS instead in my application and no longer link to OpenSSL but I am still getting a failure joining with SDKERR_UNITIALIZE.

I’ve also tried this:
ZOOMSDK::StartParam meetingParameters;
meetingParameters.userType = SDKUserType::SDK_UT_NORMALUSER;
meetingParameters.param.normaluserStart.meetingNumber = 123456;

Seriously, can I get some assistance with this??

How on earth do I troubleshoot this? This was working on Sunday.

There is a Zoom log file but it’s unreadable by human eyes. How can I examine this? The “documentation” at says “SDK is not initialized before the use” which means nothing.

If the initialisation of the SDK failed, InitSDK should have failed but doesn’t.
If the initialisation of the SDK failed, SDKAuth should have failed, but doesn’t.
If the initialisation of the SDK failed, auth service Login should have failed, but doesn’t.
The only failure is at GetMeetingServiceWrap().Start or GetMeetingServiceWrap().Join.

How can I get better support on your SDK than waiting a week for a response??

With sys internal’s Process Monitor I can see that it is loading all of the z* dlls in the SDK successfully (and Visual Studio also shows it loading those modules), and can also see it enumerating my Firefox profile directory (why???) and reading/writing these files before uninitialize is returned:

The db is a sqlite3 file but there’s nothing useful in there.

How can I find why the SDK is unloading??

I have modified the code to use the 32bit sdk.lib and statically link that instead of using the wrapper from the C# SDK (where I used to build wrapper into a wrap.lib and link that).

Now it does even less! It now doesn’t even authenticate. I can see from tracing network connections using a nirsoft utility that it reaches Zoom’s US servers but onAuthenticationReturn fails with AUTHRET_NETWORKISSUE.
If you ask the SDK for an informative error message is says “Should not be an error. Something wrong with SDK.”.
This is not helpful at all.

A second attempt at authenticating doesn’t even call the “onAuthenticationReturn” callback and so just sits there forever. You can see from a network trace that the connection has been dropped but the callback is not returned.

How can I get this SDK working? Is there something you’ve disabled on my account remotely or something???


Hello could I get some help on this please? It has been 3+ days since asking for help.

What other channels are there for getting support on this? How can we use the Zoom SDK or encourage its use if we can’t get help on it when it doesn’t work?

Hello it’s been 5 days and I still cannot log in using the SDK on multiple machines.

Can I get a response please?

Hi side.parting,

Thanks for the post and pardon the late response. We have increasing demands recently so we are expecting some delay here.

Regarding your questions:

If you have successfully initialized the SDK but still getting this error, it could be some of the SDK services gt impacted on your machine and became unavailable to use. I am not able to reproduce this error on my side so I would need some help from you for further investigation. Please have a try with the following:

1). Please try to download the latest version of Windows SDK from Github( again, and replace the files in your /bin folder with those in your project’s bin folder.
2). If this issue persists, could you provide the SDK log for us to further investigate? Here are the steps to enable and to retrieve the logs:

i. When initializing the SDK , set the InitParam.enableLogByDefault to be true, then the log feature will be enabled

ZOOM_SDK_NAMESPACE::InitParam initParam;
initParam.strWebDomain = strWebDomain.c_str();
initParam.strSupportUrl = L"";
initParam.enableLogByDefault = true;
m_bSDKInit = CSDKHelper::Init(initParam);

ii. Build and run your SDK app, after experiencing the issue, then exit the app normally.
iii. You will find the log file in: %appdata%/zoomsdk/logs/

Yes, we use OpenSSL, and we are using 1.1.1e

Hope this helps. Thanks!

Hi side.parting,

I would also like to confirm the following: Are you getting this issue with our demo app (demo_v2)? Or with your own project that integrates Zoom SDK? Is our demo app working well on your machine?

Looking forward to hearing from you. Thanks!

Thanks for your reply. I built the demo app and that worked and logged in and created a meeting.

I could not debug the demo application because the debug version of the 2017 project does not include any include paths, nor does it have anything in the linker directives, so you get this:
zoom-sdk-windows-master\demo\sdk_demo_v2\stdafx.h(20,10): fatal error C1083: Cannot open include file: ‘UIlib.h’: No such file or directory

It won’t link on VS2019 if you link against zoom-sdk-windows-master\demo\duilib\lib\DuiLib_2017.lib on the debug build, so I can’t debug it.

I have enabled logging and can see a log in ZoomSDK\logs but the log is completely unreadable - is it a binary format?

Do I need to send it to you?? I can’t read it.

Hi side.parting,

Thanks for the reply. Did you launch the sdk_demo_v2 project by opening this file: And you will need to set the Solution Configuration to Release and the Solution Platforms to x86.

The SDK log is encrypted. Would you mind placing the log in a shared drive (such as Google Drive) and share with me?


Hi Carson,
Thanks for replying. Yes I managed to build the release version of the sdk_demo_v2_2017.sln but the debug version is missing include paths or linker directives of any kind.

The log files are here:

I would be interested in what you find. My 32 bit application is linked against sdk.lib as well as libcurl (using schannel) and ixwebsockets (which is linked against zlib and mbedTLS).

Hi side.parting,

Yes, currently we only support “Release” version as mentioned in

Thanks for sharing the log file, I will forward it to the engineering team for investigation and I will get back to you as soon as I heard back from them.


Hi @side.parting,

Thanks for providing the log. Based on the log file, the SDK authentication failed due to network error(curl error 56). Please double check your network status and make sure the SDK app has the proper permission to connect to the internet.

Hope this helps. Thanks!

Does the Zoom SDK use curl then?

I don’t see mention of curl anywhere in the licence of the Zoom SDK which would be a violation of curl’s licence requirements?