Signature is invalid, Joining Meeting Timeout error

I am integrating zoom SDK on a website. After downloading the SDK and generating my client ID and client secret, I added the client ID and client secret to the appropriate places on the SDK J’s files.
On joining a meeting I get an error “Joining meeting timeout signature is invalid” but after clicking on the retry button for 2 to three times, the meeting will start successfully.
I need assistance with this as all the resources I’ve seen online does not really address the challenge.

perhaps you have problems with the iat of the signature

default: iat should be “current time - 30 sec

sometime you need more in the past

Here is the script that generate the signature. Nothing like iat in the code. I am using the direct code from zoom apk files. Note that i am not using any framework too. Just vanila js, htm and css just the way i downloaded the sdk files,

var signature = ZoomMtg.generateSDKSignature({
sdkKey: SDK_KEY,
sdkSecret: SDK_SECRET,
role: meetingConfig.role,
success: function (res) {
meetingConfig.signature = res.result;
meetingConfig.sdkKey = SDK_KEY;
var joinUrl = “C:/Users/CGX/Downloads/zoom-sdk-web-2.9.7/CDN/meeting.html?” + testTool.serialize(meetingConfig);
// console.log(joinUrl);, “_blank”);

here is a example on github , where you can learn how zoom works

the CDN version is ready to use with a few simple steps

CDN/js/index.js:20 var SDK_KEY = "YOUR_SDK_KEY";
CDN/js/index.js:26 var SDK_SECRET = "YOUR_SDK_SECRET";
CDN/js/index.js:112 ... "/meeting.html?" // replace '/' with './'

CDN/js/meeting.js:31 leaveUrl: "/index.html", // replace '/' with './'

here is a tutorial on youtube

you can check your signatur here

and you can decode exp and iat here

Thanks so much. I used these exact folder structure you shared and the youtube video to set up my project. I dont know why the signature error persist and i make sure the CLIENT ID and CLIENT SECRETE im using are correct

A NOTICE: you can only use CLIENT ID and CLIENT SECRETE, if your Meeting SDK app was first created after 12 February 2023

for ‘older’ Meeting SDK apps you need SDK Key and SDK Secret

if your app was created before 12 February and you have no SDK key/secret you have to create a new app
(there was a problem when creating the Meeting SDK app at the beginning of this year)

Update: but if you get into the meeting with multiple clicks - it can’t be because of that

Thanks so much @Jurgen. I am aware of the changes in the zoom API. I created this app last week with the resources you shared earlier and I’m using client ID and client secret instead of SDK key and SDK secret.

This error still persist please

the included function “ZoomMtg.generateSDKSignature” (-> zoom-meeting.[version].min.js) has a fix 30 sec offset and cannot be changed


you should check if the time on your computer is adjusted correctly - if the time is set incorrectly, it can lead to problems such as yours

this function is ONLY for testing embeded into the library and has to be replaced later with a function on the webserver - there you can adjust all values - example

if its done correct on the server, the time of the server and not that of the client is relevant

My system date is correct. I couldn’t find the file meetings.min.js you referenced and the meeting.js fine in the SDK J’s folder does not have similar script

Please I am also facing same problem. I have tried every possible soltions I know and some I have read. I guess there is something I am still doing wrong…

you can find zoom-meeting-2.9.7.min.js on github

if you change anything - you have to host the zoom CDN files on your web server

what EXACTLY happens if you want to join a meeting?

Ok thanks I’m going to check that out though I’m using the SDK files on zoom market place directly

Screenshot 2023-02-24 101704
This “Joining meeting timeout signature invalid” is the error i get once i try to join a meeting either as host or attendee. But when i click on the retry button like 2 or 3 trils the meeting will start successfully

I am just testing out the SDK integration and on both starting a meeting (role=1) and joining (role=0) I keep on getting Invalid Signature error message.
I really don’t know if there is still something I am supposed to do on my SDK App that I did not do.

Thanks for your help

1 Like

We are having similar issue. My own will start once i click retry maybe 2 or 3 attempt

In my own case, I does not start at all. I have tried the RETRY button several,time and its same message I keep on getting.

did you check your signatur here ?
what is the result ?

Thanks for your help. I checked and it was INVALID!
I am surprised. because I use the PHP code sample on the signature page to generate the signature.
See attached screenshot.

… PHP code sample on the signature page …

this is probably for the JWT Signature (deprecated)

there a two different versions of signatures

JWT Signature (deprecated) → all times in Milliseconds
SDK JWT Signature → all times in Seconds

for the currents zoom sdk you need the SDK JWT Signature