The Mach-O in bundle MobileRTCScreenShare.framework isn’t consistent with the Mach-o

App Store Connect Operation Error
Invalid Mach-O Format. The Mach-O in bundle “xxx.app/Frameworks/MobileRTCScreenShare.framework” isn’t consistent with the Mach-O in the main bundle. The main bundle Mach-O contains arm64(machine code), while the nested bundle Mach-O contains armv7(machine code) and arm64(machine code). Verify that all of the targets for a platform have a consistent value for the ENABLE_BITCODE build setting.

App Store Connect Operation Error
Invalid Bundle Structure - The binary file ‘xxx.app/Frameworks/MobileRTCScreenShare.framework/MobileRTCScreenShare’ is not permitted. Your app can’t contain standalone executables or libraries, other than a valid CFBundleExecutable of supported bundles. Refer to the Bundle Programming Guide at https://developer.apple.com/go/?id=bundle-structure for information on the iOS app bundle structure.

App Store Connect Operation Error
Invalid Info.plist value. The value for the key ‘MinimumOSVersion’ in bundle 3DNA.app/Frameworks/MobileRTCScreenShare.framework is invalid. The minimum value is 8.0

App Store Connect Operation Error
The binary is invalid. The executable ‘xxx.app/Frameworks/MobileRTCScreenShare.framework/MobileRTCScreenShare’ has type ‘OBJECT’ that is not valid. Only ‘EXECUTE’ is permitted.

Version that I have used
v5.2.41739.1022

I have tried the earlier solution provided in this link

Please help me

Hey @vijayraghav953,

Thank you for using the dev forum!

First thing to verify is that all of your targets have bitcode set to NO, in their build settings.
The next thing to verify is that MobileRTC.Framework is set to “Embed and sign”, and that MobileRTCScreenShare.Framework is set to “Do not embed”.

If those two things do not fix the issue, can you provide a screenshot of your framework settings for all of your targets? Please omit any confidential information.

Thanks!
Michael

Thanks a lot @Michel
It solved my problem.

1 Like

Hey @vijayraghav953

Awesome! I am super happy to hear :slight_smile:

Please let us know if you have any other questions.
Thanks!
Michael