Unable to create meeting via api

Description
Unable to create meeting via API

Error
{“code”:300,“message”:“Request Body should be a valid JSON object.”}

Which App Type (OAuth / Chatbot / JWT / Webhook)?
JWT

Which Endpoint/s?
https://api.zoom.us/v2/users/userId/meetings

Additional context
i am continously getting {“code”:300,“message”:“Request Body should be a valid JSON object.”} below is the Json body. "{ ““topic””: ““Demo Zoom API””, ““type””: "“2"”, ““start_time””: "“2021-05-06T17:00:00"”, ““duration””: ““120"”, ““timezone””: ““UTC””, ““agenda””: ““DEMO Meeting””}”

Hi @vinit.patil,

It looks like your JSON request body is invalid—I see that you have extra quotes around each field. You will want to make sure you’re formatting your body correctly. I recommend leveraging the embedded Postman tool located in our documentation on the bottom of this page for reference :slight_smile:

Thanks!
Will

Hi Will,
I was able to create the meeting. The issue was the bodyType selected was “application/xml” instead of “application/json” hence it was showing invalid json object.

Hi, @vinit.patil,
Glad to hear you able to resolve that issue. Should you have any additional questions or comments, please let us know.

Best,
Donte

Hi @donte.S ,

I have one question related to the JWT Token. I do not want the JWT Token to expire. At the moment it expires after every 90 min. Even if i increase the expiration time, it sets back to 90 min again. please suggest how can i set the expiration time for a longer time.

Hi, @vinit.patil,
Great question! Aside from the App Credentials tab in the Marketplace (see screenshot below), you can set the expiration time for a longer time at https://jwt.io/ . Timestamps are in Unix epoch format.

App Marketplace Screenshot:
Screen Shot 2021-05-11 at 9.12.34 AM

Best,
Donte

Thanks Donte, Could you please give me steps to perform this as i haven’t done this before. i tried but i think i am missing something.

Hey, @vinit.patil,
Happy to help, here’s how to set the expiration time in the Marketplace:

  1. Sign-in into the App Marketplace
  2. Navigate to the Manage screen, select your JWT APP
  3. On the App Credentials tab, select the View JWT Token drop down arrow
  4. Next, select one of the radio options to set the expiration time

Please let me know if this helps.

Best,
Donte

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.