Unable to submit app despite validated domain

Description
I am attempting to submit my app (Howie) for approval, but the submit button is disabled. I have filled out all the necessary information and have successfully validated my domain.

Thanks for your help!

Hello @sarah.at.howie please make sure all the disclaimers are accepted and the required sections are filled out you can also clear your cache and give it a try again if it still doesn’t work let us know.

Regards, Kwaku

Hi Kwaku,

I triple checked that all necessary fields are completed, and the status says ready to submit. I tried clearing my cache and cookies and have run into the same issue.

I am still unable to submit the application. Here’s a screen recording:

Thank you for your help.

Sarah

Hello @sarah.at.howie the only screen I am seeing is the last page can you show a recording with all the pages so that we can take a look and fins out whats missing?

Regards, Kwaku

Hi Kwaku,

I would prefer not to screen record the entire application as there are sensitive information like tokens.

I would be happy to jump on a call with a Zoom team member to figure out why the form is not submitting - despite me quadruple checking the completed fields and the UI itself saying “application ready to submit” with no visible errors.

Thank you.

Sarah

Let me move this to DM, this is not a support page its a forum, so if you want support you can contact our support team.

Regards, Kwaku

Hi Kwaku,

The issue was that the app owner had to submit the app. There was no copy saying that app collaborators could not submit the app.

Resolved it by having the app owner submit it. Thanks.

1 Like